I have a Logitech m525 mouse that I use at work (Win 7 32-bit). For the first little while, I would take the mouse home with me which meant unplugging the Unifying receiver. After a few times doing this however, I noticed that if I plugged the Unifying receiver back into a previously installed port, it wouldn't work. Over time, I've actually run out of ports to plug this device into. I get the following "USB Device Not Recognized" error:

enter image description here

Looking in my device manager, I see that there is a "Unknown Device":

enter image description here

and in the devices properties status I have the following:

Windows has stopped this device because it has reported problems. (Code 43)

I've tried uninstalling and updating the driver, to no avail. I've also downloaded SetPoint, and installed previously when I first installed the mouse. It still doesn't work. My question is two fold:

  1. I have a gut feeling that there are residual corrupted drivers, hence the "Windows has stopped the device...". How do I completely remove ANY drivers associated with this device?
  2. Is there a proper way to install the Logitech Unifying receiver for Windows 7?
  • This is NOT behavior of a broken/worn down unifying receiver. I've just plugged in my Desktop and everything is working fine!
    – user186758
    Jan 9 '13 at 19:11
  • @MaratKoshoev did you plug it into another usb slot? Jan 9 '13 at 20:11

11 Answers 11


I had exactly the same problem, just watched this simple video on YouTube.

Basically the steps are:

  • taking the black cap off
  • sticking a piece of paper inside making the contact points closer
  • stick the black cap back on

I tried it and it works.

  • 3
    I had found this video too, does in fact work, in fact the intermittent behaviour i had, working on some ports not on others at random times, the idea that the contacts were not contacting properly made a lot of sense. Nov 4 '13 at 17:22
  • I can also confirm the solution works. I tried it yesterday and have had no more problems. Also, the problem was in Windows and Linux, so I was able to quickly narrow the issue down to hardware.
    – Abram
    Apr 2 '14 at 17:35
  • 1
    I was able to fix using a modification of this technique, since I couldn't get the cap to pull off. When I was pulling on it, I noticed the contacts moved up and down. I bent it enough to push the contacts up a bit and now it works fine.. Aug 26 '15 at 20:35
  • 1
    This works only because the metal contacts on receiver pcb are worn up to a certain length and when you do it, you give it a tiny extra amount of metal. This will work only temporarily, until you plug/unplug it several times and the extra metal scrathes off too. I tried it at first, but the receiver died after few weeks again. I got it working again by cleaning and covering the contacts with tiny amount of solder and putting a new metal on it, but again it worked only for some time, and it's dead now. Strangely, this time the new contacts I made are NOT worn off, so there must be more to it. Jun 28 '16 at 8:42
  • I only had the receiver a few weeks and it already does not work anymore. When I move the black cap, I can see the contacts on the other side moving up and down. Dec 3 '19 at 22:23

This is typical behavior of a broken/worn down unifying receiver. The only way to fix this is to purchase another. However, you'll have to setup your old devices to the new receiver using Logitech's software.

This may have to be done with each new computer you use the mouse/new unifying receiver with. Although after a fresh install of Windows 8, my receiver picked up the mouse just fine without any of the Logitech software.


If the Receiver isn't being recognized it is not necessarily broken. I plugged my t600 receiver into my pc (win 7 64bit) and i am having these same problems. I move over to my laptop (windows 8) with the same receiver and i can use the mouse with no difficulty. There is something about windows 7 64 bit that is having issues with this. Test your receiver on a different device before claiming its broken. or returning your product. Chances are you may be able to make this work.


A bit late to the party but this worked for me. For some reason the usb.inf file was missing or corrupt for me.

Browse to 'C:\Windows\System32\DriverStore\FileRepository\usb.inf_amd64_neutral_e2b28ecac19a29af'

Copy usb.inf and usb.PNF to 'C:\Windows\INF\'

Update drive on unknown devices

-- In Device Manager, right-click and select Properties

-- Select Driver tab

-- Click 'Update Driver' button

-- Select 'Browse my computer for driver software'

-- Enter 'C:\Windows\INF\' in the Search for driver software in this location field and click Next

  • That fixed several driver issues for me. I don't know why Windows didn't search 'C:\Windows\INF\' by default. Nov 30 '15 at 23:58

I'm pretty sure I ran into this problem after Acronis Backup & Restore 11.5 imaged my disk to a .tib file.

Both the source system and the target system were apparently missing C:\windows\inf\usb.inf afterwards.

I copied it over from my netbook and an 'Update Drivers' later, had my logitech k400 wireless keyboard working again.

This seems to have affected not just logitech unifying receivers, but all USB Composite Devices. My Android tablet is also affected, as well as my Microsoft Xbox 360 USB Controller receiver, since it has two 360 pads sync'd to it, but my wired PowerA Minix360 is not affected. My microsoft wired keyboard 600 and logitech V220 are also not affected, as they are not 'USB Composite Device', but 'USB Human Interface Device'.

USB Composite Device is used to wrap up multiple child Devices in a single parent Device, such as two USB Human Interface Device endpoints (One for keyboard, one for mouse) like the Logitech Unifying Receiver does.

Big thanks to lucvdv of answers.microsoft.com for figuring it out:

Some time ago, my system stopped recognizing some, but not all USB devices.
USB ports are fine, it reads the device descriptors but then either says
it's unknown hardware or says it can't find a driver for it.

A second symptom that must have started at the same time is that it
"forgets" all about some USB devices that have always worked fine before, 
with the same result: suddenly either "unknown" or "can't find a driver".

Two weeks ago, it was my keyboard.  
It still worked when I logged on (it had to, I used it to enter my password).
Immediately after logging on, the found new hardware thing popped up,
after a few seconds it said it failed to install my new hardware, and at
that moment my keyboard stopped working.
Never found a solution, I've been using a PS2 keyboard instead since.
I've tried other USB keyboards, it didn't recognize any of them.

Yesterday, it was the USB hub that's built into my monitor that
suddenly turned into an "unknown device", and nothing I connect
to it is detected anymore. 
In an attempt to fix that, I launched the device manager and let it
scan for new hardware.

Result: instead of my USB hub starting to work again, my 
Logitech wireless mouse stopped working. 

The "USB receiver" is now listed with an exclamation mark,
"drivers for this device are not installed".  
It worked fine just a few seconds before. 
Right now I'm back to using a wired USB mouse, but I wonder how
long that's going to keep working.

It's not the receiver that's at fault: when I plug it in,
it shows up in device management with the right name and device ID:
USB\VID_046D&PID_C52B&REV_1201 - USB\VID_046D&PID_C52B,
and status "The drivers for this device are not installed. (Code 28)".

Comparing the contents of %SystemRoot%\Inf to another Win7-64 system,
I noticed that file USB.INF was missing.
Copied it over from the other system, started device manager and
re-installed drivers for the non-working devices, and the problem is fixed.

Thanks for your patience in tracking it down, lucvdv!

  • I have the same issue just now. Unifying receiver(s) works only in one USB-port and everywhere else I've got "Unknown device". Manual driver installation fails too. usb.inf was absent but search over disk C:\ shows five identical copies. After copying that file into c:\windows\inf\usb.inf and reboot everything works like a charm!
    – Kondybas
    Jan 10 '14 at 23:32

My Logitech USB receiver had similar problems to those above. Drivers were not available or couldn't be found. I tried everything. Turned out it was a problem with the last Windows Update 2/13/2018. The link below shows you how to go into the Device Manager and command prompt to uninstall the last update. Not sure if it only uninstalled it or if it uninstalled and then re-installed with a fix, but my mouse and keyboard are working again. See link and explanation below.


After installing this update, some USB devices and onboard devices, such as a built-in laptop camera, keyboard or mouse, may stop working. This may occur when the windows update servicing stack incorrectly skips installing the newer version of some critical drivers in the cumulative update and uninstalls the currently active drivers during maintenance. Microsoft is working on a resolution and will provide an update in an upcoming release. Workaround steps are available in KB4091240.

USB devices may stop working after installing the February 13, 2018 update (KB4074588) Applies to: Windows 10


After installing the February 13, 2018 security update, KB4074588 (OS Build 16299.248), some USB devices and onboard devices, such as a built-in laptop camera, keyboard or mouse, may stop working for some users. Cause

This issue occurs when the Windows Update servicing stack incorrectly skips installing the newer version of some critical drivers in the cumulative update and uninstalls the currently active drivers during maintenance. Resolution

Method 1: Restoring your system when a working keyboard is available

If a working wireless or PS2 keyboard is available, or if you can use the on-screen keyboard via a working touchscreen, follow these steps to restore your USB functionality:

In the search box on the taskbar, type cmd. Right-click (or tap and hold) Command Prompt in the search results and select Run as administrator. In the Command Prompt window, type the command listed below for your version of Windows and press ENTER. For 32-bit versions of Windows: dism /online /remove-package /packagename:Package_for_RollupFix~31bf3856ad364e35~x86~~16299.248.1.17 For 64-bit versions of Windows: dism /online /remove-package /packagename:Package_for_RollupFix~31bf3856ad364e35~amd64~~16299.248.1.17 Restart Windows.

Use the links for a clearer instruction....they didn't copy well into this.


Have you tried unplugging the power cord from your computer (and removing the battery in case you're using a laptop) for 30 seconds?

The receiver should be recognised and working again the next time you start windows.

  • 1
    This is a desktop. Aug 14 '12 at 15:03

This is often an electrical problem between the USB receiver and the laptop USB port. It will work in some laptops and not others depending upon how well-made (and worn out) the laptop USB port is.

I opened my 2 Logitech receivers (as suggested in the youtube video) and the four copper pads appeared highly corroded with a great deal of black oxidation on the leads. I could not get them to work by stuffing a piece of paper between the circuit board and USB housing, as suggested in the video, but I was able to hold the USB receiver inside the laptop USB port with my hand and it was recognized. However a few moments later and I probably quivered and lost electrical contact, and it said, "USB port not recognized" after having formerly recognized it.

You probably need a new receiver, or you can follow the youtube video, take apart the nub, and try to put it together so it will work. I must say, you may not have good luck, the manufacturing quality of this USB transceiver is horrible, Logitech, shame on you!

I paid $12 on ebay to purchse two new USB transceivers shipped from hong kong.


In my case, the copper line (path, whatever) was broken. You need to connect it by soldering. It will work. I attached a photo with a possible broken line (see photo). It was #3 in my case. First, open it with pliers than pull out the logic board and fixsee the logic board and possible broken line place. Hope it helps!


I had a similar issue. In my case I found the USB receiver actually pushed slightly too far in to the port. It somehow detected as an HID Mouse but did not install properly. If I pulled it back out just a millimeter it would kick in and work just fine.

FIY you can also clear old drivers sometimes by right-clicking on your main drive and selecting: Properties > Disk Clean Up > Clean Up System Files > Check all boxes.

This can sometimes clear stored but unused old drivers that you might want to update or just re-install fully.

  • 1
    That indicates your port or receiver were faulty and/or broken. Nov 8 '20 at 4:26

Per the post above, copying usb.inf and usb.pnf worked for me and got my Logitech Unifying Receiver and wireless mouse working.

In my case I had to copy them from: C:\Windows\System32\DriverStore\FileRepository\usb.inf_amd64_neutral_f636e83c550b20d0 to C:\Windows\inf

Machine is a Dell T7600 running Windows 7 64-bit.

If you are getting the same problem and aren't seeing the usb.inf_amd64_neutral_e2b28ecac19a29af folder, try usb.inf_amd64_neutral_f636e83c550b20d0 instead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.