I have a MacBook Pro running OS X Lion 10.7 and somehow I changed the behavior for the Fn key.

Whenever pressed, it shows me the desktop.

It's driving me crazy because some applications require a combination of the Fn key plus something else, so whenever I press the combination it still shows the desktop.

| |
  • Have you installed any apps that change keyboard behavior? – slhck Aug 7 '12 at 16:30
  • Not that I can remember... I'm almost 99% sure that I have not, I usually don't install programs to tweak my system. – MikeGA Aug 7 '12 at 20:55

OS X El Capitan 10.11

I found it, after years of searching.

System Preferences> Mission Control> Show desktop> Drop down menu change "Fn" to "-".

This has been the most annoying, niggling problem.

| |

I recently had the same problem. I got rid of this option by going to System Preferences > Misson Control. Where it says 'Show Desktop' it will say a key on the keyboard. Make sure it says 'fn' unless it does already. Then change it to '-' and this option will be gone :)

| |
  • I tried your suggestion but it doesn't allow me to change it to a dash '-' my computer just beeps, I can add a different shortcut but the 'fn' key is still showing me the desktop!! – MikeGA Aug 7 '12 at 20:53

My guess is that the Fn key was accidently set as a shortcut. In my experience with MacBooks, any "Key" related issues can be found here:

Apple Menu > System Prefrences... > Keyboard

Foe the Specific Shortcut you mentioned, I would check the "Show Desktop" in the "Keyboard Shortcuts" Menu.

Mine is set as F11. Make sure Fn does not appear there.

| |
  • It seems impossible to even set Fn as a single shortcut key in OS X. Have you tried it? – slhck Jul 31 '12 at 7:50
  • Ha. Excellent point... I went through all this trouble but did not test the actual "fn" button. Sorry about that. I'll look a little further, but I'm currently stumped. Did you try "Restore Defaults"? – Brad Jul 31 '12 at 17:43
  • It's not me who had the problem :) – slhck Jul 31 '12 at 18:00
  • Another excellent point (clearly a newbie at superuser...). MikeGA, I would suggest "Restore Defaults" to see if that helps. – Brad Jul 31 '12 at 18:04
  • I have upgraded to Mountain Lion hoping it would restore it but I still have the same problem, at the screenshot above I can change the show desktop shortcut to something else but It doesn't remove "fn" behavior, it still shows me the desktop!! I'm very frustrated!! – MikeGA Aug 1 '12 at 17:51

This was driving me nuts too but I managed to find a fix for it, it's similar to bradpfeiffers solution above but resets all keyboard defaults at the same time.

Go to System Preferences > Keyboard In there I reset everything to default though I am not sure this is absolutely necessary. I also unticked everything to do with Mission Control.

Go to Mission Control Preferences Untick all four options and change all four of the keyboard shortcuts to '-'

Then go back to Keyboard Preferences and reset defaults again.

Now my Fn key no longer shows the Desktop! I think it must have been a hangover from when I upgraded to 10.8 from 10.6.

| |

This was driving me crazy too. My solution was:

System Preferences > Accessibility > Keyboard > Enable Sticky Keys

| |

For me, the issue was with the default setting which was changed without me noticing it - getting back to Expanded Control Strip did resolve the issue and the ESC key is back when I need it.

my setting

| |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.