7

I have a mac book pro running osx lion. I was using a wireless keyboard for awhile but don't want to anymore. Now every minute or so the the keyboard is trying to reconnect. I don't want to shut off bluetooth, because i use a track pad. I'm worried that this is something malicious trying to connect to my computer as well as being ridiculously annoying. I've had to reject three times in teh course of this message. Please help!

Just an update to state the things i have tried. I've gone into the bluetooth prefs and removed the entry from the list of paired devices and it just comes back less than a minute later.

  • 5
    Turn off the keyboard? Remove it's batteries? – RedGrittyBrick Jul 31 '12 at 13:58
  • That's not really solving the issue, just avoiding it. I want to understand why this is happening. I did shut off the keyboard, but the second it turns back on, it starts trying to connect to my computer. Also this all hardware provided to me by my work. If a new person comes to the company they may need to use that keyboard, and then need to turn it back on. – aamiri Aug 1 '12 at 16:05
9

My office mate was ready to shiv me for stealing control of his wireless keyboard every morning. Plus, he would always get mad and start typing, usually right as I was finishing up some long Unix command in Terminal. Then it would come to blows.

So finally, the olive branch:

In terminal, I did the following:

sudo rm /Library/Preferences/com.apple.Bluetooth.plist
rm ~/Library/Preferences/com.apple.Bluetooth.plist

Then, I turned off bluetooth, and turned it back on. Opened System preferences and selected the bastard's keyboard and clicked the 'minus' button.

Appears to do the trick. We get married in March.

  • This doesn't work for me. – harperville Jul 20 '15 at 12:57
2

Open "bluetooth" in system preferences, hover over the keyboard and click the big "X".

Also, if you followed Alien Life Form's advice (like I did) ... once you turn your bluetooth off with your bluetooth mouse you can turn it back on again with your wired keyboard by either:

  • hitting cmd + space (to open spotlight), typing "blue" (top hit should be bluetooth file exchange), and hitting enter.
  • alternatively hit cmd + tab until you find a browser, hit cmd + t until you get a new tab, hit up google with "enabling bluetooth without a mouse osx", and then thank christ that they have their s#!t together with accessibility (unlike the rest of us).
1

I had the same problem. I have a hearing aid device (Soundgate) that hangs around my neck (no removable batteries) and transmits to my hearing aids (a nifty idea that works great), but though the Soundgate device was switched off, the bluetooth button was still on and was continually trying to pair, causing the pop-up mentioned above every 2 minutes.

I finally discovered that the bluetooth button on the device had to ALSO be turned off as well.

I have been helped so many times by these online Q&A's, I sure hope this helps someone as well!

0

Zap the P-RAM (paramater ram) thrice. Works like a charm (restart your Mac while holding down four keys: Command-Option-P-R). Wait for the POST bong three times, then let the keys go. Your Mac will forget about trying to pair with a bluetooth keyboard until you TELL it to pair with a bluetooth keyboard. FYI not even AppleCare could help with this one.

0

Check your batteries!

I had some old rechargeable batteries which I swapped in, then this started happening. I swapped them back, and the problem went away.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.