The output of my program being too long, on running it in screen terminal some part of output gets truncated.
To avoid this how can I increase log limit of screen terminal?
Any ideas??

  • Maybe try redirecting output to a file? Such as ./myprog < out.txt
    – squiguy
    Jul 31, 2012 at 13:18
  • 2
    @squiguy - Did you mean: ./myprog > out.txt instead? Jul 31, 2012 at 13:35
  • Yes, essentially just redirecting the output! I got mixed up unfortunately.
    – squiguy
    Jul 31, 2012 at 13:41

3 Answers 3


this depends on the terminal you are actually using.

e.g. for the xfce4-terminal, go to "Edit->Settings->General->Scrollback" and change the scroll-buffer to your likings.

for kde's konsole, go to "Settings->Configure current Profile...->Scrolling->Fixed number of lines"

the classical xterm can be configured with a startup-flag -sl 777 (for 777 lines of scroll-back buffer) or via the saveLines config.

given that there are quite a number of terminals out there, you might want to check the manpages for the one you are using...:-)


To increase the scrollback buffer for GNU screen (I assume this is what you are using from your question), start it with screen -h <buffer_size>. Unfortunately, it appears the scrollback buffer cannot be resized after startup.

To set a new default scrollback buffer in GNU screen, add defscrollback <num_lines> to your ~/.screenrc file.


When you are already using a screen session, hit Ctrl+A, then type :scrollback #, where # is the number of scrollback lines you would like.

At startup, you can use the -h argument as recommended above.

You must log in to answer this question.