I'm trying to play Minecraft in-browser with Google Chrome, but it won't ever let me trust Minecraft's certificate. When I try to run it, I get this popup:

enter image description here

Then when I click "Show Details...":

enter image description here

If I tick the box that says "Always trust 'Markus Persson'", and change "When using this certificate: []" from "System Default," it still doesn't do anything. How can I run it in Chrome?

  • which operating system are you using? – kenorb Jul 31 '12 at 22:13
  • Try opening Keychain.app and removing all certificates that could possibly be related to this. Also, open Utilities » Java Preferences and show us the output from the Security tab. You could also clear the Java cache and files from the Network tab here. Furthermore, which version of OS X are you using? Which page are you trying to access exactly (so we can try to reproduce the issue)? Which Java version are you running? – slhck Jul 31 '12 at 22:35
  • I've just installed OS X Mountain Lion today, and I got at least the downloadable minecraft to run (it didn't before). Hooray! Since it completely uninstalled Java, it installed the latest version (Java SE 6). I'll give more info if none of the existing answers do the trick. – Jwosty Jul 31 '12 at 22:49

Go into System preferences -> Security and Privacy and check the box that allows applications to be downloaded from anywhere (click the lock to make changes to this).

If it doesn't help, you can try as follows: Make sure that you don't any other windows apart this certificate, maybe it's asking for you permission in the separate window. Try as well clearing your java cache and security settings.

You may also need to reinstall the locally installed Minecraft files which you can find in your home directory.

On Windows: %AppData% (Windows+R keys, type in %AppData% at the run command and press Enter).

On Mac: ~/Library/Application Support/minecraft (your local home user directory).

There will be a minecraft directory, so try to delete everything except for the saves directory that you see therein. Then, try running Minecraft again. I'd advise you to make the backup of those files before. If you don't have any Minecraft data stored, then remove the whole minecraft directory.


  • make sure that your system date is not in the past,
  • run your Chrome in the terminal, it could give you some more information about the problem,
  • delete your browser cache,
  • try upgrade your java to the latest version,
  • Yeah, I've made sure nothing else is causing this, and I don't think it's an issue involving minecraft itself. Just the certificate. Also, I have Java SE 6. – Jwosty Jul 31 '12 at 22:51
  • Can you check as well that your system date is right? Not in the past? – kenorb Jul 31 '12 at 23:03
  • Please also run Chrome browser in the Terminal, and check if you could see any additional errors related to it. – kenorb Jul 31 '12 at 23:04
  • I think this is duplicate of: stackoverflow.com/questions/11727955/… – kenorb Jul 31 '12 at 23:10
  • Thanks, this worked! :) Also, you're right. It is a duplicate... – Jwosty Jul 31 '12 at 23:18

In Java Preferences, you may need to select "Allow user to grant permissions to signed content" on the advanced tab.

  • This is checked by default, but might of course be the issue here. – slhck Jul 31 '12 at 22:44
  • Yeah, it was already ticked... :/ – Jwosty Jul 31 '12 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.