Recently my uncle gave me his memory card from his phone telling me something is wrong with it.When i tried to check the contents of memory card this is what i found(take a look at screenshot).

I have scanned it with bitdefender it gave me a message saying 4 threats are ignored. Is there anyway to fix or recover the files. And can anyone please explain what is the reason for the gibberish file names and how to avoid it from happening again.enter image description here

  • Did you fix it? What file-system was the card? How big? Had you tried a different card-reader or system? It’s curious that there seemed to be a normal directory in there. Usually when there is a problem reading the drive, everything will be corrupt. This sort semi-corruption can occur with a bad connection (between the card and reader or the reader and the USB port, etc.) Anyone with this issue should try cleaning the pins on the card and breathing on it to add a bit of moisture to the pins to improve electrical conductivity. Also clean the pins on the card-reader’s USB cable if accessible.
    – Synetech
    Nov 29 '13 at 16:38

This sort of thing usually happens when you plug in flash disk to old PCs (Pentium IV or lower) or on PC's internal card reader with USB port. Apparently, some old USB controllers (those that were manufactured before 4-GB flash storage were developed) simply do not support USB drives larger than 2GB. As a result, the files get corrupted.

If you can still open those folders and files then I suggest you copy those files to another drive immediately. Before attempting to fix it, copy the files to another drive as backup.To fix, simply run CHKDSK on your flash drive.

If you cannot recover your data through CHKDSK then I suggest you to use a recovery software.

I just found this excellent recovery software TestDisk.

It is called TestDisk and it is a powerful recovery software. It can fix partition tables, FAT, FAT32, NTFS boot sectors, recover deleted files, copy deleted files, and many more. I suggest you go to the website, download, install and give it a try for yourself. It is easy enough to use for experts and novices alike.

Another powerful tool you can use is GetDataBack for NTFS and Fat.

Hope it helps.

  • can you tell me how to recover files from TestDisk as GetDataBack is a commercial version
    – simplyblue
    Aug 2 '12 at 19:14
  • 1
    TestDisk Step By Step. Aug 3 '12 at 17:59
  • @kinokijuf, what OS and motherboard were installed on that system? I have tried to access a large flash-drive from DOS and it was gibberish as ahmed said. Plugging in a small flash-drive in the same system worked just fine from DOS. The problem is not from a single cause, it is a combination of factors including the size of the flash-drive, the OS, the USB controller, and most importantly, the BIOS settings. You may need to adjust the BIOS setting that determines what type of drive the flash-drive appears as (e.g., fixed-disk, floppy, CD, etc.)
    – Synetech
    Nov 29 '13 at 16:31
  • Hi, this answers seems corresponding to my problem, but how can I backup files before trying chkdisk when filenames are like fscommand/Hobe3_517.app/Resources/Ѫö{.t╖│/ú╥▌7≤╛ºw.e\031\n ? I get "Input/output error"
    – Asenar
    Aug 31 '15 at 7:09

Not the answer you're looking for? Browse other questions tagged or ask your own question.