6

Once upon a time, I installed Synergy. I never use it, so now I want to remove it.

Synergy doesn't install as a "normal" Mac app (or at least it did't before), so you can't simply "drag it to the trash can" or use something like AppCleaner to remove it.

I'm sure I could search around for all traces of Synergy and delete them manually, but I'd prefer it if there was an official way to uninstall it; something that would remove it completely.

I searched around and read in several places that the installer is supposed to have an option to un-install. I no longer had the installer for this old version (v1.3.1, I think), but managed to dig it up from their website (here). However, the installer doesn't run anymore and the newer ones can't uninstall older versions, or so it seems.

Does anyone know how to remove this version of Synergy from the system completely?

  • Perhaps try installing the latest version so it updates the other components, then uninstalling it? – Oliver G Aug 2 '12 at 21:41
  • It's a good suggestion, Oliver. I've actually already tried that (forgot to mention it in my question). All I got was two versions of Synergy, running at the same time :p – Leif Aug 2 '12 at 21:43
8

I had the same issue and resolved it like this:

  • in the Synergy prefpane, turn off synergy and remove its menuitem
  • in a Terminal window, type mdfind -name synergy
  • for each file related to Synergy, remove it:
    • sudo rm -rf /Library/PreferencePanes/SynergyKM.prefPane (et c)
1

Expanding on ecmanaut's answer, you can automate this a little bit:

mdfind -name synergy | grep -v .webhistory | tr '\n' '\0' | xargs -p -0 -n 1 rm -rf --

As before, mdfind -name synergy generates a list of files (potentially) related to Synergy.

| grep -v .webhistory filters out Safari history matches, as you might want to preserve your browsing history.

| tr '\n' '\0' replaces newlines in the output with null values instead. This is necessary for xargs to properly process the file list if it contains any spaces (i.e., .../Application Support/...).

| xargs -p -0 -n 1 rm -rf -- will take every file or folder provided in the first part of the command and execute rm -rf on it to delete it. Specifically, -p asks the user to confirm each deletion (because if you have an unrelated file such as ~/Documents/Important business study on synergy.tex that will show up in the file list). -0 tells xargs to use only the null characters we inserted with tr (not spaces or newlines) to delineate file names. -n 1 processes the files individually—rather than calling rm once with the whole lot of them—which allows the user to individually decide whether to delete each file. -- at the end covers the edge case where a filename begins with - and prevents rm from treating it as a switch.

(I didn't find any Synergy files outside of my home folder, but I was uninstalling Synergy 1.7.4 from Mac OS X 10.11.1, so your mileage may vary, and you might discover that rm must be preceded with sudo in order to get everything.)

As an aside, if you don't care about filtering out the .webhistory results, this can be simplified down to:

mdfind -0 -name synergy | xargs -p -0 -n 1 rm -rf --

using mdfind to insert the null separators.

0

I had the same issue, but realized that all you do is rerun the Installer (v1.0.1), and the popup window has the following options:

  • Install Synergy for current user only
  • Install Synergy for all users
  • Uninstall Synergy (this may require an administrator password)

Selecting Uninstall option solved my problem and did not require removing files directly in the file system.

  • 1
    How to rerun the Installer. Every time I try to reinstall Synergy the Installer doesn't open... The DMG file mounts I copy the application in the /Applications folder but it doesn't solve my problem. – politicus Oct 2 '17 at 18:17
0

From the Symless website

macOS First, close the Synergy app if it's running.

Next, delete the Synergy app from the Applications directory.

Now, run these commands to remove the settings (don't worry if the files or dirs > don't exist).

rm -rf ~/Library/Preferences/Synergy
rm -rf ~/Library/Preferences/Symless
rm -rf ~/Library/Synergy
rm -rf ~/Library/Symless
rm ~/Library/Preferences/com.https-symless-com.Synergy.plist
rm ~/Library/Preferences/com.http-symless-com.Synergy.plist

Then, run this command to unload the preferences:

killall -u $USER cfprefsd

Finally, install as you would normally.

  • after trying numerous things, this is what worked for me. I think the killall is what did it. I may have also missed a few plist files. – Chad Dec 28 '18 at 17:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.