3

I changed the folder permissions of /usr/bin to 777. Now when I login to root user it shows "incorrect password".

Now I'm not able to do anything on this PC. How can I revert the permissions of /usr/bin without a terminal? I think I need to change them to 751.

I can login via CtrlAltF1, but not into root.

5

Boot off the install CD but dont install, mount the folder, and change the permissions back.

| improve this answer | |
2

I think you should use single user mode to fix this problem.

  1. boot the computer and stop it in grub menu
  2. edit the boot parameter, just append 'single' to your current linux kernel, and press ENTER
  3. after booting, you will be in single user mode, with root permission (without password) and with very few services enabled
  4. change the permission by 'chmod 751 /usr/bin'
  5. reboot and done

Hope this will help you.

| improve this answer | |
  • 1
    This is exactly what single-user mode is for. +1 – Benjamin Bannier Aug 3 '12 at 11:41
0

Maybe you should try to boot in command line mode first, I used ubuntu for a while(now I am always in fedora ), in ubuntu, when I try to change into root mode and enter the correct password, it show 'incorrect password', I did this in command line: $ sudo passwd

Password:

Enter new UNIX password:

Retype new UNIX password:

then reboot, hope this will help you

| improve this answer | |
0

You first need to check Administration. (Or)

Open the terminal. Type below command and hit Enter

sudo -i

Give your password. Now, you have a sudo. check below command

sudo apt update

Hope this will help you.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.