I'm trying to repair a Windows Vista PC booting to a black screen with only a mouse cursor on it. I can move the cursor, but the PC doesn't respond to Ctrl+Alt+Del, Ctrl+Shift+Esc, etc. It seems to be on the verge of booting, but never gets to the login screen. I've tried the following fix actions:

  • Boot into all forms of safe mode (with/without networking, command prompt)
  • Boot to last known good configuration
  • Boot with low video resolution
  • Boot from Windows 7 installation disk (full license)

When I boot to safe mode, low vid, or command prompt I receive an "Operating System Not Found" message. So, intending to start fresh, I bought a Win7 disk and that's where things got weird. The PC does the exact same thing when I boot from the Windows 7 disk. I know that it is booting from the disk because I see the Windows 7 logo on the boot screen (the shiny blobs turning into a Windows flag rather than the green progress bar). I've checked my BIOS options and they are extremely limited, I can't really change anything except the boot device order.

I am at my wits end with this PC, can anyone provide any suggestions as to what I should try next? As many of the PC specs as I know are listed below if they are of any consequence. Any and all helpful suggestions I can get would be much appreciated, if you've ever had a mother-in-law you'll understand.

  • Sony Vaio PCG-2J3L All-In-One
  • Windows Vista Home Premium (again, trying to reload w/ Win 7)
  • 4GB RAM
  • Intel Pentium processor

UPDATE 8/8/12 The hard drive appears to be bad. Here's a recap: - Re-seating the RAM got the PC to boot from USB/Windows 7 boot disk - Hard drive is inaccessible from a SATA-to-USB adapter, will not mount from Linux, and will not complete the boot in Vista. Purchased a new hard drive and will replace.

  • Downvoter, care to comment? If I'm missing information I'll gladly add it. – awilson53 Aug 4 '12 at 20:31
  • Ah, I see now that I've posted on the wrong stackexchange site...I'll post in SuperUser, apologies. – awilson53 Aug 4 '12 at 20:33
  • 1
    +1 The question is well-asked, just not in the correct site. – gWaldo Aug 4 '12 at 20:40
  • Ive seen this before. This usually happens when a driver used in the boot process is wrong or corrupt. Its a pain to fix. – Keltari Aug 4 '12 at 20:58

Try re-seating the RAM. I know how stupidly simple that sounds, but you'd be surprised! However, be sure to unplug all power!!! Even if you think the system is off, it's NOT! So unplug batteries and unplug power cords just to be sure you don't fry your RAM when you re seat it.

Even more stupid would be to forget disconnecting all USB devices (less K/B and mouse). Hopefully, I don't need to say any more there.

Then check the BIOS which I believe you said you did. But I have a problem when you say all you can do is manipulate the boot order since that's not likely the BIOS settings. Personally, I've never seen a BIOS where the date and time couldn't be adjusted. So if you can't at least set the date and time then I'd bet dollars to doughnuts that you're not really in the BIOS. Typically, you press the DEL key shortly after powering on to get into the BIOS. But that key could instead be something else like the ESC key or F1, or F2. (Sorry, I can't recall what Sony typically sets it to.) And once in the BIOS you might want to pay attention to all areas related to RAM and CPU functions. This is a whole other area of discussion but just know that even one bad setting can result in a very sluggish system.

Next you might want to check all connections and make sure you don't have a failing hard drive or something. Cause from what you said, it sounds quite likely that your HDD may be on it's last legs. (Hopefully, you have things backed up too.) Then again, you may just need to re-partition and/or re-format (which will kill everything on it). So before you do anything else, you may want to check with the HDD manufacturer and see if there isn't a diagnostic boot disk you can get (usually by downloading an .iso file and then burning it to a CD that you then boot with).

One other suggestion might be to try booting a live Ubuntu CD (which is pretty much done exactly the same way where you download an .iso file and then burn it to CD that you then boot with). And in case you didn't know, you can boot to a fully functioning (although somewhat sluggish) system when booting from a live Linux distribution such as Ubuntu. So if you can at least do that much then it's almost a guarantee that you have bad HDD or some other SATA/PATA controller issues.

I can't say if any of that would work, but those would be my first steps. Good luck...

  • Thanks for the response. I'm fighting a comedy of problems it seems. Reseating the RAM got it to a point where it would boot from my CD. Before I blew it away I tried to use my Ubuntu USB to salvage the non-backed up files (I know, I know), but fdisk -l doesn't show the hard drive at all. The consensus seems to be that if it doesn't list the drive is probably dead (although it does list in the BIOS). Does that sound about right? – awilson53 Aug 5 '12 at 1:58
  • Thanks Anon, good suggestions that got me to a solution. – awilson53 Aug 8 '12 at 12:36

I found that enabling DNS cache prevented my Win7 from booting. Why, I do not know, but I am certain of it as I repeated the following several times and it worked every time after I enabled DNS cache service and my machine did exactly as described above..boots okay to black screen with cursor, no other user controls effective. hung there.

To repair it I suggest

boot to safe mode. run services.msc disable DNS cache service. close and reboot normal.

Again, why it worked for me, I do not know. My machine was working perfectly until I enabled DNS caching then it stopped booting exactly as described. by disabling DNS through Safe Mode was the only way I got her to boot again. Good Luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.