I have an iMac that will connect to my network wirelessly, but not through the wired ethernet. The cable works fine with another computer. The network utility reports that the link status is inactive, network preferences reports that the ethernet is not connected.

My question: is the hardware faulty or is there a software, PRAM or other non-volatile setting that I can reset to bring the wired network back to life?

I have tried resetting the PRAM with Alt+Cmd+P+R and disconnecting the power for 15 seconds with no success. (But there is no feedback that the second incantation has any effect.)

I have a 2010 model, 27" iMac, 2.8 GHz i7, 8GB RAM.

I have had the same problem with the first release of OS X 10.8 and the last release of 10.7.

  • If the cable also doesn't work with any other device than your router, I'd say your Ethernet port is broken? – slhck Aug 5 '12 at 16:54
  • @slhck, sadly that is a reasonable point of view. However, many people are reporting the same problem on various forums, but none have declared whether they solved the problem with a hardware fix with a software or configuration change. Maybe we will learn something together? – Nigel Davies Aug 5 '12 at 21:13
  • I figure you already did a reinstall of the OS? Or tried another user account? Unlikely that this fixes the issue, but worth a shot. I guess no error messages in Console.app of any kind? – slhck Aug 5 '12 at 21:14
  • I had an interesting issue with my iMac that insisted the Ethernet was dead, until I replaced the network switch. – user3463 Aug 6 '12 at 5:40
  • So I tried another router and a variety of cables. The all work with my laptop and the iMac doesn't detect any of them, so I guess the ethernet port is dead. Stupid failure mode for an expensive machine. Thanks for your help anyway. – Nigel Davies Aug 6 '12 at 19:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.