I'm trying to share my "Projects" drive (F DRIVE) with the rest of my network so I can access it from my new Laptop. Upon attempting to do so, however; I received the following popup:

enter image description here

I've tried sharing other directories to no avail (same issue). This is a relatively recent issue because I already had several folders shared that I unshared and now can't reshare (sigh...).

I've read several things online making sure that certain services are running.

This is what I've come up with:

  • The service Function Discovery Resource Publication is not running and upon attempting to start it, I get an "Access Is Denied" error.

  • My computer was recently temporarily connected to a Domain Controller and I'm not sure if I was able to share folders since (not sure if I've been successful since).

  • I've already run the "sfc /scannow" command and I would prefer not doing it again. Yes, it found issues and fixed many of them (many of which I didn't really want fixed...).\

I'm willing to generate more information for you by requests in the comments. Feel free to ask just about anything.

  • 1
    File/Print Sharing is actually fairly complex and has many points of failure. I recently wrote a comprehensive article on problems with File/Print Sharing and getting it to work. Take a gander and see if it can help you get up and running. – Synetech Aug 9 '12 at 1:31

After cross-referencing information about this particular error, I've found that there are tons of posts concerning this message, being the common denominator a firewall service issue. I've found two answers on Windows Forums with the same solution, and tried out as explained below with success.

Note: This issue is also reported as malware related, try checking your system with a malware removal before proceeding.

Phase One

  1. Download this two registry files:

  2. After downloaded, right-click one and select "Merge";

  3. You should get a UAC prompt, accept it;

  4. Repeat the process for the second file;

  5. Restart your PC;

Depending on the reason behind the problem at hand, at this point you should test to see if the issue is solved. If not, continue to the next phase.

Phase Two

  1. Access your start menu and type in the search box "regedit" and press enter;

  2. Access to the following key:

  3. Right-click over it and select "permissions...";

  4. Click on "ADD", type "Everyone" on the new popup, then click "ok";

  5. Under the "Group or user names:" list, you should now see "Everyone", click on it;

  6. Bellow, under "Permissions for Everyone", tick the checkbox for "Full Control", under "Allow";

  7. Press "ok" to confirm, close the regedit;

  8. Access the start menu and on the search box type "services.msc" and it enter;

  9. Start the service "base filtering engine service";

  10. Start the service "windows firewall service";

At this point you should have the issue solved.


http://social.technet.microsoft.com - Search the first answer, posted by narenxp

http://answers.microsoft.com - Search the first answer, posted by narenxp

  • Sorry, I would also upvote but apparently but awarding the bounty, I don't have enough rep to do that. Odd :/ – Freesnöw Aug 9 '12 at 3:31
  • @Dlamk I'm glad for helping out :) This is an old problem and MS could have already come up with a way to protect their OS, or at the very least a tool to fix the issue with one click!! – Zuul Aug 9 '12 at 9:28
  • @Dlamk Anyways, about the reputation, you can confirm and read about your privileges here. To access this page you can mouse over your username on the page header, and on the right of your avatar, you will see "Privileges". – Zuul Aug 9 '12 at 9:30
  • 1
    @Synetech :: It works great now. I did everything listed in Phase one and restarted -> It worked like a charm :) – Freesnöw Aug 9 '12 at 16:39
  • 2
    @Dlamk, hmm, interesting, so the virus you had either added a rule or damaged the services. You should consider installing/enabling Windows Security Essentials (or another anti-virus) and keeping it updated. – Synetech Aug 9 '12 at 16:55
  1. Can you make sure that you have "Network discovery", "File and printer sharing" and "Public folder sharing" enabled in "Change advanced sharing settings" in "Networking and Sharing Center"?

  2. The other thing you can try, please turn on your Windows Firewall (services.msc).

  3. Also check:

    sfc /scannow

    It will inspect all of the important Windows files on your computer, including Windows DLL files. If System File Checker finds an issue with any of these protected files, it will replace it.

  4. Scan you system via Microsoft Security Essentials

  5. In services (services.msc), make sure that 'Remote Procedure Call Locator Service' and 'Base Filtering Engine' services are enabled (On) and put it on Automatic. Read more.
  6. If you have 3rd party firewalls, please temporary disable them.

For some reason I cannot add a comment to VBwhatnow's answer — so I am posting a correction here. The permissions for the Base Filtering Engine service definition should be as follows:

HKLM\SYSTEM\CurrentControlSet\services\BFE: Inherit

HKLM\SYSTEM\CurrentControlSet\services\BFE\Parameters\Policy: Explicit :=

  • SYSTEM = Full Control
  • Administrators = Full Control, Read
  • NT Service\BFE := { Query Value, Set Value, Create Subkey, Enumerate Subkeys, Notify, Read Control }

(The last one shows as "BFE", but must be typed as "NT Service\BFE" when adding it, otherwise Windows cannot resolve the name.)

Considering that the Registry entry was already broken by malware (and I am not sure I'm going to be able to reinstall this PC), it seemed illogical to hand out permissions that would allow software to break this Registry key all over again.

VBwhatnow's answer does achieve the effect of letting NT Service\BFE control this key, but it's more appropriate to restore the actual permissions. Sadly, you can't do this by way of a .reg file!

protected by Community Jun 5 '13 at 18:14

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.