I am running OS X Mountain Lion as the host, and Windows 7 inside a VMWare Fusion 4.1.3 machine. I have a local website running on the host (under port 5000).

I want to access this website from the guest. My host IP address is, and my guest IP address is

From the guest - inside Command Line - I can ping my host using However, when I go to Internet Explorer, and go to

I get a 404 error.

Under the Network Adaptor for VMWare Fusion - I have the Network Adaptor enabled and am sharing the Mac's Network Connection (NAT).

How can I resolve this problem?

  • Joerg: You're getting downvoted/voted to close because this question is offtopic for StackOverflow (SO is for programming questions). However, it's being marked as more suitable for SuperUser, which is a similar site that's more likely to give you a correct answer. I've posted a suggestion below that may help - but the whole thread will likely be migrated to SuperUser shortly! – Dan Puzey Aug 6 '12 at 9:31
  • Downvoters: this question is offtopic, but it's not a bad question: details are good and it shows some level of effort. I'd agree with closing/migrating the question, but I don't think it deserves downvotes. – Dan Puzey Aug 6 '12 at 9:43
  • Ok cool - sorry. Should I wait for it to be migrated first? – Joerg Aug 6 '12 at 10:03
  • I don't think it matters (and it may not happen - it has to be voted offtopic by five people before it'll migrate). If my answer works then go for it :-) – Dan Puzey Aug 6 '12 at 10:04

The website should be accessible on your host NAT adapter address (vmnet8).

Be sure your web server is listening on the NAT interface or all interfaces.

netstat -an|grep LISTEN
  • If they're seeing a 404 error, the server is accessible. – Dan Puzey Aug 6 '12 at 9:29
  • @Dan Puzey. You're right, I was focalized on the Bridged/NAT aspect of the question and missed the 404 error. – Sam Aug 6 '12 at 9:42

A 404 error is the server telling you that the page you've requested does not exist; if you're getting a 404 error then that indicates that you are getting to the server.

I'd suggest you either add a valid page name to the url (e.g. or make sure there's a default document set on the website. But the important point is: this is not a networking error.

  • 1
    (I had tried that as well - but to no avail). I could even put in a random IP address into Internet Explorer - and it kept on giving me a 404 error. I looked through the various options inside IE - and found that it was connecting via a proxy - which I removed, and now it works! – Joerg Aug 6 '12 at 10:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy