A few days ago I accidentally ran a malicious script on my netbook. This stopped my power options working, System restore was faulting when I tried to load it (service not running), my Windows theme looked like Windows 2000, I had no audio (the list goes on) and my internet didn't work via my browser or LAN. After hours of investigation I realized all it appeared to have done was disable all my services. So, into services I go, and enable them as needed.

All now work other than networking.

This is what I've tried to so far

  1. Making sure I have internet connection - I used another computer or mobile phone and it connects wireless fine.
  2. I plugged a cable into my netbook and it works, indicating the issue must be the wireless.
  3. Uninstalling the network card in device manager and re-installing it.
  4. Disabling the network card in device manager and re-enabling it.
  5. A ping of the router fails on wireless.
  6. I have no local network either.
  7. In command prompt, typing IPCONFIG returns the message that the media is disconnected. (FYI this means it's not functioning as expected more than the device is physically dis-connected)

If I open up Network Connections, I can see my Wireless Network Connection is disabled. Right clicking it and selecting enabled does not change the state (it remains disabled). Diagnose does not help or provide anything further.

I have tried changing the IP v4 to static / dynamic and this has no effect (it's normally dynamic).

When I open IE and click Tools, Internet Options is greyed out (meaning I can't select it). I opened it with no add ons, and it worked. I return to IE and it now works.

Thankfully, my netbook (Lenovo thinkpad with W7 starter) comes with a quick start (a dual boot) and when I enter the 'Nix OS, it connects with the wireless fine. Therefore, a service (or driver) is faulting in Windows.

Any other suggestions what I can do to try?


Under Control Panel > Network and Internet > Network connections you should see your network adapter. (On W7, Control Panel > Network and Sharing Center. In the new window, on the left size of the screen, click Change adapter settings).

Right click on your wireless network connection > Properties, here you should see what "services" are used by this connections.

Activate the one you think you'll need (if you don't know which ones, all of them shouldn't be a problem or get inspired from you're wired connection).

Make sure that IP v4/6 are set to DHCP: double-click on Internet Protocol v4/6 and select Obtain an IP automatically.

  • Thank you - I have updated my question as I had tried this - however, my Wireless Network Connection is set as disabled and I can't just enable it - no error message when I click enable, it just doesn't change state.. The IP v4 is set dynamic - the DNS tab is fine as well / DHCP is enabled.
    – Dave
    Aug 8 '12 at 10:25

In this instance, the fix was a System Restore (but only after re-enabling the services)!

Thank you to MSIS for your help.


I had a similar problem and I tried un-checking all boxes under the properties option. I then bridged the IP v4 and v6 boxes and it did work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.