I have an old Windows system here with a strange problem. Whenever I plug in my USB WLAN adapter the mouse and keyboard both become unresponsive. The system does not hang because other processes visibly keep running.

The problem does not occur with other USB devices such as memory sticks or external harddrives.

It's also not an issue with the WLAN adapter itself because I've tried two different adapters from different vendors, both show the exact same problem.

They register correctly, show up in the device manager if I keep it open and windows pops up the little balloon saying "No wireless network connected" or something but both mouse and keyboard become completely unresponsive.

Any thoughts?

EDIT: FWIW the system is a completely clean install of WinXP SP3

  • 1
    "I've tried two different adapters from different vendors" - for argument's sake, are you sure the chips in those adapters aren't the same? Most of this stuff is off-the-shelf. – Shinrai Aug 8 '12 at 17:27
  • Good question, I just checked one is a LinkSys which uses a Ralink RT3070, the other is an older Sitecom WL-172 which is also apparently a Ralink but I haven't been able to figure out which one exactly. – PeterD Aug 8 '12 at 17:37
  • What's the hardware being used? Laptop/Desktop? And the USB, is 1.0/2.0, for last, the brand and model for those WLAN Adapters? – Zuul Aug 8 '12 at 18:01
  • So, just to be clear, the keyboard and mouse are cabled USB devices, not wireless? Are you plugging the Wi-Fi adaptor into the keyboard, or a different USB port? Can you see from the hardware device tree if there's a separate USB controller/port on your system, so you can plug the USB Wi-Fi adaptor into a completely separate USB bus than then one the keyboard and mouse are on, preferably handled by a different USB controller? Does that make a difference? – Spiff Aug 8 '12 at 19:57
  • @Zuul Desktop, USB 2, Sitecom WL-172 and Cisco Linksys WUSB100v2 – PeterD Aug 9 '12 at 21:23

I spent a few more days messing with it, installed various versions of windows and Linux and have come to the conclusion that the motherboard is probably the problem. The onboard LAN isn't working either, and plugging in a pci ethernet card also causes problems.

I've never seen an issue like this that specifically affects networking hardware but there you have it. Case closed(?)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.