The OS is Windows XP and the program is Microsoft Office Standard 2007 (Excel). This computer recently upgraded from Office 2003 to Office 2007 (Yeah, I know don't shoot me).

Upon clicking any .xls or .xlsx file Excel 2007 will open and stop there. The file itself will not open traditionally. The workaround thus far is to then go into the menu and select Open and select the file that way, then the file opens. Microsoft Word does not have this same issue; the files open correctly.

The .xls and .xlsx files are already associated with Microsoft Excel 2007. Any help is appreciated.

  • Is the associated program using something like "%program files%\office\excell.exe" or "%program files%\office\excell.exe" "%1"? (note the %1 which is an argument. In this case the file name. And it might need quotes to work on file names with spaces in them. – Hennes Aug 9 '12 at 20:07
  • Interestingly I just noticed if you double click on an Excel Document and then try to manually open (CTRL + O) a different document and then close the CTRL + O document the double clicked excel document pops up instead of just closing the document (which it does also). @Hennes It is c:\Program Files\Microsoft Office\Office12\EXCEL.EXE Not sure where to find that path anywhere except in Windows Explorer - I go Open With > Microsoft Excel to select it to always open. – cyborgcommando0 Aug 9 '12 at 20:37

Go to http://support.microsoft.com/kb/211494 and it will give a very clear explanation of how to make it so Excel opens the file. I searched on: "Excel 2007 'There was a problem sending the command to the program'" since that was the error message.

Open the Excel application. Here are Microsoft's instructions from that link - very simple to follow!

Microsoft Excel 2010

Click the File tab, and then click Options.
Click Advanced, and then click to clear the Ignore other applications that use Dynamic Data Exchange (DDE) check box in the General area.
Click OK.

Microsoft Office Excel 2007

Click the Microsoft Office Button, and then click Excel Options.
Click Advanced, and then click to clear the Ignore other applications that use Dynamic Data Exchange (DDE) check box in the General area.
Click OK.

Microsoft Office Excel 2003 or earlier versions of Excel

Click Options, on the Tools menu.
Click the General tab.
Click to clear the Ignore other applications that use Dynamic Data Exchange (DDE) check box, and then click OK.

Even if the option Ignore other aplications that use Dynamic Data Exchange (DDE) is already clear (false), click to enable and then click to disable.

After you do this, you should be able to open workbooks by double-clicking them in Windows Explorer.


Using @Hennes direction I ended up opening a Windows Explorer Windows and navigating to Tools then Folder Options. Then in the new window I selected the File Types tab.

From there I navigated to XLS and selected Restore and then that button became Advanced. I clicked Advanced and started to edit the line that says Application Used to Perform Action:

At the end of the string there was a %1 which I changed to "%1". I repeated this process for the XLSX extension as well. After closing the window I was able to double click and immediately open any excel files without any issues.

  • 1
    I am happy to hear you got it working. :) – Hennes Aug 10 '12 at 23:40

When you double click on a program then windows XP checks the file association to see which action to take. One of these action is to check a list with extensions which you can find under [Tools] [Folder option] [File types]

Screenshot of My Computer, tools tab, option folder options

if you have ms office installed there will be several listen file extions here, e.g. `xslx'. (I got no access to computers with ms office atm. I am at home where I use open office. Hence more more precise screenshots).

If you click on an extension it should show which program it opens with, an option to change the program and a tab advanced.

Image of the file associations

Office programs seem to default to using DDE. Check if this is the case by going to [Advanced] and [Edit]

enter image description here

If the tick mark is not there you just found your problem. Mark it and test again. :)

If it is there and the problem is very recent, first check for the XDocCrypt.A/Dorifel virus (New since yesterday. Quite virulent and messing with both excel and word files).

Sometimes you run into situation where the DDE option is marked but does not work. Not even after de-installing and reinstalling office. I am not sure what causes that problem, but I have worked around that in the past by defining my own action via [New], selecting excel as the program to open it (use browse) and adding "%1" behind the program.

(If you do not add anything clicking on and .xlsx file will start Excel. it will not pass the file name and you will still look at an empty spreadsheet.

Adding %1 will pass the file name. It will work as long as the file name does not contain space. Else double clicking on my test.xlsx will open excel and tell excel to try to open the file my. Which will fail.

Adding "%d" should work, even for files with spaces in them.

1) I used to use that with office 2003, not 2007. It should work the same though. 2) I am mostly recalling stuff I did 2 years ago. I might have skipped a step. 3) Fully untested with 2007 and xslx, since I do not have access to office 2007 atm.

Please let us know if it worked, or if I need to clarify some points.

  • This seems very helpful! However I cannot edit the XLS filetype only restore it. I can edit the XLSX filetype and go to advanced like your images show. When I go to Application used to perform action I have "C:\Program Files\Microsoft Office\Office12\EXCEL.exe" /e. Adding %1 or "%d" does not help. I'm not sure if I'm doing this correctly. Also, opening .xls does nothing and opening a .xlsx will prompt errors like you say but still open the spreadsheet. – cyborgcommando0 Aug 9 '12 at 22:57

I had this problem after installing Office 2016 (Office 365). I kept finding the instruction about the DDE option, which did not work for me. The following solved it for me:

  1. Open Control Panel
  2. Open Programs and Features
  3. Select Microsoft Office
  4. Click Change button at the top
  5. Select Quick Repair.

This took me something like 3-4 minutes. This solved it for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.