8

Does anyone know how to disable the blinking power LED when Vista enters hybrid sleep mode? My case has a very bright blue LED that is rather distracting. I'd rather not disable hybrid sleep, as it works perfectly and allows for much faster resumes than restoring from a hibernated state.

  • The bright blue led illuminates my entire room at night; I know exactly what you're talking about! – Paul Lammertsma Mar 27 '10 at 15:08
7

No you can't. The blinking is controlled by the motherboard, not control by the OS.

You can try to put some tape to cover the LED or unplug the LED light from the power supply though.

  • 3
    I ended up unplugging the power LED. Not my first choice, but it solved the problem. – Anthony Giorgio Sep 25 '09 at 12:24
  • Good to know. That's what I did to my case also, the blue LED was too bright. – deddebme Sep 25 '09 at 17:51
1

Well, to add theoretical hardware solutions: if the LED is too bright, adding a simple resistor will do the trick. A somewhat neater if more speculative hack would be to add a passive low-pass filter which is nothing but a resistor and a capacitor. If you get it right, it would turn your blinking LED into a pulsing LED which is maybe less distracting and might look better. However, LEDs don't have a linear response curve, so you should prepare for the payoff not looking quite as cool as you would have liked. Also, I won't be held responsible for anyone trying this and bricking their mainboard.

0

This is not exactly what was asked here, but since there is no software way to disable lights in sleep mode at the moment and this question is linked as duplicate for a different one (so I can't post there), I post here what was extremely useful for me and can be useful for others:

First of all, I have:

  • Windows 7
  • Z170-P motherboard

What I wanted:

  • no PC light at night
  • restore all applications statuses at morning, when I turn PC "on"

The asnwer was to use S4 (hybernation) state instead of sleep (S1-S3) state. I didn't know about that before, but those a different modes. The main difference is that S4 is slower than sleep, but takes less power to sustain and power LED won't blink.
Here is how to anable this state and bind it to keyboard or power button.

Now, some lights are still on in this state. I was able to turn them off too, using ErP option: go to BIOS->Advanced->APM->ErP and switch to "Enable for P4/P5".

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.