I have an external USB 3.0 HDD which uses a sector size larger than 512 bytes (4kB). In Linux, I created a truecrypt encrypted partition on it, which works fine on any Linux or Windows Computer. However, the MacOSX truecrypt version seems to have a major issue with drives that use a sector size larger than 512 bytes. Trying to mount the encrypted partition in MacOSX results in the following error

Error: The drive uses a sector size other than 512 bytes.

Due to limitations of components available on your platform, partition/device-hosted volumes cannot be created/used on the drive.

Possible solutions: ...

I can use unencrypted partitions on that HDD (an iomega eGo 1TB USB 3.0) without a problem, even partition the drive from within OSX.

The truecrypt version history for version 7.0 mentions that

Partition/device-hosted volumes can now be created on drives that use a sector size of 4096, 2048, or 1024 bytes (Windows, Linux). Note: Previously only file-hosted volumes were supported on such drives.

but they seem to still not have addressed the problem for MacOSX. I already filed a report of this 2 years ago in their official forum, but no one seems to care about it, nor to know any solution or ETA when this will be fixed. Other people answered to this forum post who have the same problem, even with other drives, so it is not just me.

Performance on file-hosted volumes is bad, so I need partition based encrypted volumes.

Subsequently I tried to do the thing from scratch in MacOSX - I partitioned the drive in OSX and tried to create an encrypted partition with the OSX version of truecrypt. The exact same error from above appears.

Does anyone have an idea how to circumvent the problem and use drives with a larger sector size than 512 bytes in OSX with truecrypt to create/use partition based encrypted volumes?

I am surprised that the truecrypt folks haven't address this issue yet for OSX. Didn't 512 bytes sector sizes become obsolete?


1 Answer 1


This site has some details of how the author removed the messages, and then tested and debugged the underlying problem in TrueCrypt (there IS an underlying bug), building his own version with the fixes. The author has binaries available, if you trust him.

  • 4
    Could you please give some information in the answer rather than just a link.
    – Chenmunka
    Commented Jan 6, 2014 at 12:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .