My Epson SX235W has lost it's network connection for no apparent reason. The settings for my wireless network haven't changed - other wireless devices can still connect - and (as far as I can work out) the settings on the printer haven't changed either. I haven't enabled MAC filtering, the wireless password hasn't changed, the SSID of the network hasn't changed.

I've tried both reinstalling the printer software from the installation CD and reconnecting the printer via the "Wi-Fi" button on the front panel. In both cases the printer goes away for 5 minutes attempting to communicate and comes back with either:

Communication error

or a flashing orange light on the front panel. There is no other information as to what is wrong.

The router seems to think that the printer is connected. It has an entry for the printer called "EPSON2C11F5" and has assigned it an IP address. However if I try to ping that address I get "Destination host unreachable.". Unfortunately I don't know whether that's because the printer doesn't respond to pings or really is unreachable.

What other options do I have?

The printer part is working fine when I connect via USB - it's just the wireless networking that's failed.

  • @fixer1234 - I've just nuked the comment. I can't remember what I searched for to find it now. – ChrisF Apr 17 '17 at 21:34

10 Answers 10


I found the solution. It seems that with every change of network configuration, even with a new computer start, turning the printer off and on again etc., the printer may request/receive a new IP from the router.

So the trick to fix it is to find out the new IP of the printer (I am doing that via the router admin interface), then run "Start" - "Epson" - "Epson Scanner Configuration", and there I delete the existing scanner from "Network Scanner Address" and add a new one with the correct IP. Clicking "Test" should find the scanner now.

After that, refresh the scanner list in the software (it may be 'cached' with an old IP address) and run a scan - for me it works ever since! (well unless my printer receives a new IP, aargh!!)

| improve this answer | |
  • The best thing to do is to give the printer a fixed IP address. You can do that on the printer (or via its browser interface). Just make sure the address is well outside the normal DHCP range (e.g. if the printer is now, make it Alternatively you can reserve an address for it on the router. – hdhondt Aug 27 '12 at 0:47
  • I don't have that menu/option. I'll dig around this area though. – ChrisF Aug 27 '12 at 10:11
  • @hdhondt: if I enter the printer's IP in the browser, it forwards to some empty subpage only displaying the printer model. How else would I get to the "browser interface" of the printer, is it a certain port or so? Unfortunately, my router doesn't seem to allow me to set a fixed IP for a certain Mac address. – richey Aug 27 '12 at 22:15
  • @ChrisF: on my computer (Win7), it is in "Programs"-"Epson"-"Epson Scan"-"Epson Scanner Configuration". HTH... – richey Aug 27 '12 at 22:16

You can reset the settings on the printer by holding down the Network info button as you turn the printer on and then run the disc.

| improve this answer | |

I had similar - for me, using the Wi-Fi button didn't help but the original CD did as the CD did a network scan and set up the communication (if you have this option).

| improve this answer | |
  • I did try reinstalling via the CD. – ChrisF Aug 10 '12 at 13:09
  • In that case, if you can, shut down all network devices in the building. Boot up with router first, wait 30 seconds, then PC, wait and then printer + mobile phones etc. – Dave Aug 10 '12 at 13:10

Perhaps your router upgraded itself? And the updgrade disabled some older, less secure encryption? Which your printer happened to use?

Anyway, I would try factory reset and reconfigure wireless settings.

| improve this answer | |

Definitely a weird problem this.

I rang Epson support and they just said "try resetting the router" - hardly inspiring, but I thought I'd give it go. So I reinstalled the software and drivers (having previously left them uninstalled on my previous attempts) but this time I selected the "WPS" option.

Lo and behold the printer found and connected to the wireless network without a hitch. Though the orange light is still flashing an hour or so after the installation.

| improve this answer | |

A factory reset on a SX235 is done by turning the printer off, and starting it while holding the Information button and start button down, at the same time for 10 seconds.

| improve this answer | |

We have two laptops sharing an Epson Stylus TX550W over a wifi router, one of which runs Windows 7 Professional 32-bit and the other Home Edition 64-bit. After Windows Updates automatically to both laptops, the printer would no longer print.

After a great deal of mucking around, the answer for me was to:

  1. Go to Control Panel > Programs and Features, and delete all Epson software, e.g. Scan, Easy PhotoPrint, EpsonNet Config, and the drivers.

  2. Go to Start > Printers and Devices and delete all printer instances installed by the installer CD.

  3. Download the latest versions of all Epson driver and utility software installers, and reinstall.

  4. Go to Start > Run, and enter %WINDIR%\system32\spool\printers, then delete all files in this folder.

  5. Go to Start and search for Services, then stop and start the Printer Spooler service.

  6. Launch EpsonNet Config and wait until the Epson Stylus TX550W details display, then write down the MAC number if you are using MAC filtering in your wifi router.

  7. Click the TX550W line, and click the Configuration button.

  8. In Device properties, go to Network Interface > Network > Basic (Wireless).

  9. Type the PSK key, e.g. password, required to access your wifi router.

  10. If you are using MAC filtering on your wifi router, log in to its configuration page and type in the MAC number of the printer into the MAC table of values.

  11. If your printer has been added to the Printers and Devices control panel, delete it again.

  12. In Printers and Devices, right-click and choose Add Printer.

  13. In Add Printer, click Add network, wireless or Bluetooth printer.

  14. When the list of printers display, click the wifi network printer, and click Next.

  15. Print a test page. The printer should now be successfully installed.

| improve this answer | |

I struggled with this problem for over a year! I even replaced the printer and I still had the problem. I finally found the solution on the Comcast support forum.

Here is the solution:

  1. Use a static IP address on your printer. Look in your user's manual and find a way to set the IP address on your printer so it doesn't change even you reboot your router. On my Epson, I go into the control panel and use the "Manual Wi-Fi Setup".

  2. Routers have a setting called "AP Isolation". This setting, if enabled, isolates the Wi-Fi clients so they cannot see each other. Make sure the AP Isolation is disabled. Now, here is my problem. I had the AP Isolation disabled. However, after a few weeks, I could not hit the printer. It just wouldn't connect ("unreachable"). After reading the Comcast post, I turned the AP Isolation setting on (Enabled) and then I saved my settings. Then, I turned the AP Isolation back off (Disabled) and I saved my settings again. The wireless connection worked again! Yea! So, apparently my Cisco M20 router just starts isolating the AP clients for no reason after a few weeks even though the AP Isolation setting is disabled. Yesterday, I downloaded a new firmware for my router and I installed it. I am hoping that this firmware solves the problem permanently. However, if the printer becomes "unreachable" again, I will simply turn on AP Isolation, save settings, then turn off AP Isolation and save settings again.

Best wishes!

| improve this answer | |

I also had problems printing wirelessly to my Epson TX550W after recent Microsoft updates. After all the usual stuff like restarting computers, routers, printer, checking settings - all to no avail - still nothing would print. It seemed the printer was not communicating properly. Although it was detectable on the network I could not check the ink levels from my laptop. After a lot of trial and error my successful solution was to re-run the Epson Network setup wizard that came with the original installation disk and which was sitting in my Epson program folder. A pity the troubleshooting tool didn't suggest this option as I wasted many hours.

| improve this answer | |

Do you have neighbour with broadband? If so, then you may have to change your router settings. Instead of using the default auto channel selection, change to a manual selection ie channel 1 - 12. This worked for me after hours of searching for remedy Had no problem since. I think my printer was trying to communicate with neighbours router and caused conflict.

| improve this answer | |
  • Connecting your printer to your neighbor's internet is quite a different problem than what OP had. – music2myear Apr 17 '17 at 20:58
  • @music2myear, my read is that the neighbor had a strong signal that was confusing the printer into trying to connect to it rather than the in-house network. – fixer1234 Apr 17 '17 at 21:04
  • 1
    The printers I've worked with have you choose the network they should connect to. If the SSID was the same, there's a chance of what he says, but if not, that's just a big case of user error. – music2myear Apr 17 '17 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.