I recently moved and switched to a new ISP. Since it was hooked up, I have been having experiencing a minute or two of "Connection Reset" whenever I try to navigate to a new website. This occurs every 5-15 minutes. It occurs in both firefox and internet explorer.

I am behind my ISP's cable router, which I then plug into my own Belkin Wireless router. The computer on which I am having the issues is a laptop I run on wireless. The error also occurs when hard-wired to the belkin. I cannot reproduce it on my Asus tablet, connected wirelessly.

It mostly occurs on new websites (hinting at a DNS error), however not always (Youtube has issues loading the actual video when the rest of the page loads fine, along with others). I will also navigate to a new page on a website to see the ads replaced by the same error. I attempted changing my DNS servers to OpenDNS, but this did not alleviate the issue (I may not have properly flushed the old settings however).

I also found this pointing to a MTU error. I checked my MTU on windows 7 and the output was:

enter image description here

which I believe is correct.

At this point I am out of ideas as to how to fix this problem. Any ideas as to what to try next (or detailed instruction on how I should recheck something I have already done) would be greatly appreciated.

In response to Deloader's answer, I attempted to change the MTU on my Belkin Router to 1500, since a ping of 1472 to google went unfragmented. The instructions I found for doing so (shown here) changed it, but this caused me to lose internet connectivity. After a hard reset of the router, I am back where I started. I will agree that the MTU appears to be the problem, however I do not know how to change it for a dynamic connection type (which I have), since the above instructions were for a pppoe connection (which I don't have).


Try changing MTU value in router to 1492.

If still problem persists, use the following command in command prompt

ping www.google.com -f -l 1500

Reply "Packet needs to be fragmented but DF set." means MTU is in higher range. Keep reducing the number or start with 1400 or 1386, till you are getting proper ping replies. Once you start getting proper ping replies keep increasing the value and add 28 to the max value for which you are getting proper reply, that is your MTU. change MTU to this value in the router.

  • Ive been combating this issue for days now (there are quite a few posts about this problem on the site). Now it works, thank you. But I'm curious, where does the "magic" number 28 come from? – mizipzor Aug 13 '12 at 17:48
  • My router was set to 1454. pinging google at 1472 got my replies I needed, so I reset it to 1500 using the directions here. This then caused my router to lose internet connectivity (I am assuming since I am not on a pppoe conenction) until I did a factory reset on it. Now my issue is just finding out how to do this another way. – Godric Seer Aug 13 '12 at 22:18
  • You add 28 bytes because 20 bytes are reserved for the IP header and 8 bytes must be allocated for the ICMP Echo Request header. – Deloader Aug 14 '12 at 1:21

The incredibly simple solution was that I simply restarted my laptop. I am assuming since the laptop had never been connected to this style of modem, it was missing some configuration that required a reboot to take effect. The symptoms have disappeared (at least for the last 20 minutes or so). Never underestimate the simple solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.