1

Whenever I apt-get something, it warns me that it is unauthenticated. This is a new problem; it started today. When I do apt-key update, it does nothing, and apt-get update gives me this error at the end of its output:

W: GPG error: http://archive.canonical.com precise Release: The following signatures were invalid: BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
W: GPG error: http://ppa.launchpad.net precise Release: The following signatures were invalid: BADSIG 30C0868B8020F06A Launchpad PPA for arand
W: GPG error: http://ppa.launchpad.net precise Release: The following signatures were invalid: BADSIG 5C92FC592AE51AB5 Launchpad PPA for consindo
W: GPG error: http://ppa.launchpad.net precise Release: The following signatures were invalid: BADSIG 3BDAAC08614C4B38 Launchpad otto06217

Does anyone know what's happening or how to fix it? I'm running ubuntu 12.04 (precise).

1

ref: ubuntuforums.org

sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update
  • Thanks. That seems to have done the trick. I'll accept the answer when I can – pbfy0 Aug 12 '12 at 17:22
  • your welcome .. have a great day. – tao Aug 12 '12 at 17:23

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.