I installed Windows 7 and Windows 8 in EFI mode on a hard disk some days ago. Today, the bootloader got missing/corrupted.

I currently have the Windows 8 installer on a flash drive and tried using the Automatic Repair option to repair the bootloader but it didn't do anything. The Startup Repair option is also missing in the Windows 8 installer.

How I can repair/recreate the EFI bootloader from the Command Prompt?

BCDEDIT returns the following message:

The requested system device cannot be found.
  • What is wrong with the current solutions?
    – soandos
    Commented Aug 26, 2012 at 0:33
  • @soandos I had the same problem. I executed the commands from you and harrymc, and everything works fine now! Many thanks to you both.
    – ComFreek
    Commented Sep 7, 2012 at 13:14
  • 2
    Just as an FYI, but we've recently released an automated EFI repair tool for Windows 8: neosmart.net/blog/2013/… Commented Mar 5, 2013 at 16:36
  • 1
    I did not expect people to be having so much trouble with UEFI windows 8... How does the system partition just vanish or get corrupt anyway? It's not even mounted in windows normally so filesystem corruption can't be it. And all current OSes are bug-free enough not to muck up an existing windows installation. In fact, even windows doesn't muck up linux on UEFI, surprise of surprises.
    – Milind R
    Commented Feb 11, 2014 at 20:01
  • This doesn't apply if you're using Dynamic disks
    – rainabba
    Commented May 24, 2015 at 16:20

9 Answers 9


I've spent a lot of time trying to get my Windows 8 PC to boot again after cloning to a new SSD and try to summarise how I finally got it all working -

Firstly, boot from a UEFI Windows 8 recovery disk (CD/DVD/USB) - I found that the automated recovery process didn't find the correct Windows partition, nor when I managed to add it to BCD settings would it make it reliably bootable e.g. using BCDEDIT I got it to find and launch the Windows partition but it refused to cold boot or would not "keep" the settings after a 2nd reboot or power off.

Go into the Advanced options and run the Command Prompt.

Enter diskpart to use the DiskPart tool to ensure you have all the right partitions and to identify your EFI partition - the key thing here is that your EFI partition is formatted as FAT32:

DISKPART> sel disk 0

Disk 0 is now the selected disk.

DISKPART> list vol

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 0     E                       DVD-ROM         0 B  No Media
  Volume 1     C                NTFS   Partition    195 GB  Healthy    Boot
  Volume 2         WINRE        NTFS   Partition    400 MB  Healthy    Hidden
  Volume 3                      FAT32  Partition    260 MB  Healthy    System

Then assign a drive letter to the EFI partition:

DISKPART> sel vol 3

Volume 3 is the selected volume.

DISKPART> assign letter=b:

DiskPart successfully assigned the drive letter or mount point.

Exit DiskPart tool by entering exit and at the command prompt run the following:

cd /d b:\EFI\Microsoft\Boot\

bootrec /fixboot

Delete or rename the BCD file:

ren BCD BCD.bak

Use bcdboot.exe to recreate BCD store:

bcdboot c:\Windows /l en-gb /s b: /f ALL

The /f ALL parameter updates the BIOS settings including UEFI firmware/NVRAM, /l en-gb is to localise for UK/GB locale. The localisation defaults to US English, or use en-US.

Reboot and cross your fingers.

This gave me headaches. I was going in circles for a long while. There isn't a lot of reliable info about fixing UEFI/Windows 8 at the time of writing.


To re-enable Hyper-V, I also had to run the following from an Administrator Command Prompt within Windows after rebooting:

bcdedit /set {default} hypervisorlaunchtype Auto
bcdedit /set {default} nx OptIn
  • 1
    Did this from a windows 10 download ISO. didn't work at first, but ran the startup repair in the GUI menu afterwards and that did it, thank G-d. :-) I appreciate the help :-)
    – Abbafei
    Commented Apr 2, 2017 at 21:51
  • this recipe felt the most promising but i hit BFSVC Error: Could not open the BCD template store. STatus = [c000000f ] :( Commented Aug 1, 2017 at 20:21

The other answers are helpful but this is what I had to do to fix mine.

I had a 1.5 TB hard drive with Windows 7 installed on it. I then installed Windows 8 onto a 150 GB SSD I bought. The 1.5 TB hard drive failed and I could hear it making a noise, my computer would no longer start, saying "please insert system disk". I thought that the bootloader was missing as it must have been on the 1.5 TB disk. It turns out it was but the problem then was the guides I followed would not rebuild the bootloader or whatever it is called as i did not have an EFI partition on the smaller 150 GB disk (this may have existed on the failed disk), it only had 1 partition which filled the entire disk.

I did not want to lose all my data so I entered the Command Prompt by booting from my Windows 8 install USB drive (noting that you cannot boot the UEFI version of this if that appears, select to boot from the just the USB drive without the UEFI appearing before it).

Once in Command Prompt (see the other answers for instructions) you need to shrink the partition. To do this, enter the following commands, pressing Enter after each one:


list disk

select disk 0

list partition

select partition 1

shrink desired=200 minimum=200

create partition efi

list partition

select partition 2

format fs=fat32

These commands will create the EFI partition. Double-check everything by typing list vol. You should see a 200 MB partition. You now need to assign it a letter. Do this by typing assign, then list vol again to see what letter has been assigned.

Now this is done you need to copy the boot files to this newly created partition:

bcdboot C:\Windows /l en-gb /s B: /f ALL

Note: you must replace C: with the drive letter of the partition that contains Windows, and B: with the letter assigned to the EFI partition you just created.

I also entered the following commands:

bootrec /fix

bootrec /fixmbr

These both came back successful, no idea if they really did anything but who cares. Windows is now fully recovered.

  • 2
    bootrec /fix doesnt appear to be a valid command on windows 8 but otherwise the instructions worked and solved all my problems. Thanks! Commented Jul 4, 2014 at 8:15
  • i: is my EFI partition (first on the disk), but it's empty. When I run bcdboot c:\windows /s i: /f ALLI get "BFSVC Error: Failed to set emement application device. Status = [c00000bb]" I've been fighting this battle for months and with each attempt, keep ending up with a flash drive that seems to contain my EFI boot files because I I can boot off of it, but if I remove it, I cannot boot.
    – rainabba
    Commented Jul 10, 2015 at 17:32
  • Thanks a lot! This saved my day. I tried virtually everything out there and nothing worked. The step I was missing was the formatting the EFI volume. Once formatted the EFI volume. bcd boot command worked successfully and I have my windows 10 back up and running again.
    – Sahil
    Commented Mar 31, 2017 at 20:47
  • +1 for telling me to choose the windows drive letter instead of the usual C:
    – ptetteh227
    Commented Apr 6, 2018 at 9:14
  • +1 - Remember the most important sentnce Note: you must replace C: with the drive letter of the partition that contains Windows, and B: with the letter assigned to the EFI partition you just created. I fight with that by 13hours! Thanks man you save me next 12 hours :) Commented Oct 18, 2019 at 19:16

Okay, I've had time to put together a proper outline here. It's long, but it's pretty complete and should help you see what's going on.

First, one way this can happen:

  1. Your BIOS loses its settings.
  2. No problem, all that stuff's stored in the EFI partition.
  3. ...except for the SATA IDE vs AHCI setting, for obvious reasons.
  4. Were you using SATA-AHCI? You're probably using SATA-IDE now.
  5. Did you try to boot before you figured that out?
  6. If you did, it failed. Did you let Windows try to fix it?
  7. If you did, BLAM, it may very well have destroyed the Boot Configuration Database.
  8. Make sure you're using the correct SATA setting you were using last time.

Here's what you've probably done by now. IF ANY OF THIS DOES NOT MATCH, CAREFULLY EVALUATE WHETHER THIS IS IN FACT YOUR PROBLEM, and READ this for ideas but don't FOLLOW it without thinking first.

  1. You have HOPEFULLY ignored all the crap about fixing the Master Boot Record (MBR), partition table, partition flags, and other garbage that DOES NOT APPLY to an EFI boot scenario. AT ALL. At best, you would be able to completely rebuild a new, unrelated, NON-EFI boot solution. That might not be trivial, however, because:
  2. You have figured out that Windows is certain it does not have a Boot Configuration Database, but it is, unfortunately, either completely clueless or VERY certain about where it goes-- you can't quite tell which.
  3. You're aware that the boot store is normally (somewhere)\Boot\BCD and that the file is HIDDEN; view it using dir /a:hs.
  4. You've familiarized yourself a bit with BCDedit.exe and figured out that it will let you "mock up" a Boot Configuration Database in a staging file using /CreateStore (and please don't name it "BCD"), that you can explicitly use the staging file with the /Store option, that you can add a menu entry for the Windows Boot Manager using /Create {bootmgr}, and that you SHOULD be able to import it using /Import...
  5. ...but when you try to do this, you can't. You look into the /SysStore option, which sounds right, but you can't get it to use another store because it's "ambiguous". You have a hunch that it knows where the store is-- or should be-- but you can't find it.
  6. You've tried to use MountVol to mount the EFI partition, but it doesn't even show in the list, so you can't.

If ALL of that applies fairly closely to you, here is what MAY be going on:

  1. Windows can tell you're set up for EFI (you have booted the DVD via a UEFI boot, you have an EFI partition, etc.).
  2. It therefore knows WHERE TO LOOK for the BCD file-- however, it either somehow has the location wrong (not this problem, but similar) or the BCD has been deleted.
  3. Apparently, because it knows where it SHOULD be, this breaks /SysStore-- and actually, that's probably correct behavior, because otherwise you'd put it in the wrong place.
  4. As near as I can tell, MountVol deliberately hides the EFI partition (or is somehow incapable of noticing it). This prevents mounting the filesystem, which prevents finding the correct subdirectory, verifying that the database exists, etc.

So here, finally, is what you need to do about it. The good news is that it's probably a lot simpler than you're hoping by now.

  1. You do indeed have to mount the EFI partition.

    Actually, I have a hunch that's not strictly correct-- I strongly suspect the EFI partition is already mounted by some internal subsystem, which is why BCDedit gets cranky-- it doesn't see the database, but it knows where it should go. Whatever it does not have, however, is a drive letter. So-- what to do?

    Well...how far back do your DOS roots go? Do you remember the Assign command? Guess what.
  2. Start DiskPart.
  3. If you are not familiar with DiskPart, the way it basically works is a hierarchy of sets; you must select exactly one element at one level to proceed to the next. So, List Disk, and then Select Disk n where n is whatever's appropriate for you.
  4. Use List Partition and List Volume (note non-plural) to get some insight and identify your EFI partition.

    It is usually a 100MB FAT32 partition marked System. Keep in mind that your disk should be using a GPT partition table by now, so you may see quite a few partitions. Some of these are for emergency recovery-- fat lot of good they do for EFI problems, eh? Oh well.

    Notice that the EFI partition, and a few others, do not have drive letters. If you're so inclined, you can also view the GPT partition attributes, which may give you a few tangentially-related "Aha" moments as well.
  5. Select Partition n where n is the EFI partition. (I expect you could select the volume instead if you need to.)
  6. Assign. That's it. Don't specify a drive letter; just Assign.
  7. List Volume. You should now see a drive letter assigned to the EFI partition.
  8. Exit DiskPart.

    And now... a big fat warning. You will probably go directly to S: (or whatever you got from Assign) and notice a Boot partition. "AHA!" You will say. "There is no BCD file here!" First... remember that file is hidden. Second... dig around a bit more, and you will notice that while there is S:\EFI\Boot and also S:\EFI\Microsoft\Boot

    You need to check both of these for problems. S:\EFI\Boot is for the motherboard, and contains the Windows Boot LOADER (and possibly other things for other operating systems). This has this name because the motherboard has no idea if you're going to have Windows or not, and needs a fixed path that makes sense.
  9. Inspect S:\EFI\Boot. For Windows 7 Professional, 64-bit, you should see: bootx64.efi
    If you have installed an EFI shell (always a good idea), you might additionally see shellx64.efi.

    NOTE: Dual-boot Linux users using chainloader+1 WILL NOT see an extra entry here.
  10. Inspect S:\EFI\Microsoft\Boot using both dir and dir a:h. For Windows 7 Professional, 64-bit, you should see a bunch of language templates (en_US, etc.) and the following files:
    ...except that you probably don't see BCD, do you? But those backup files sure look tempting.
  11. Determine which backup file you want to use. Whatever recent changes it's missing are nowhere near as important as your ability to boot the system, so go for the one that's most intact. Probably you will see one large one and one fairly small one. The small one is already corrupt, and is an artifact of the failed repair process-- don't use it. If they're both large, use the older one. IN ANY CASE, make ADDITIONAL BACKUP COPIES OF THE BACKUPS somewhere else.
  12. Copy the backup you've decided to use to BCD.
  13. Exit the shell, shutdown cleanly, and reboot.
  14. Tell Windows to start NORMALLY. At this point, it should start.

Q: What if you don't HAVE a backup BCD?

A: Well, that really shouldn't happen. It likely means you're either in the wrong directory, support EFI but weren't actually using it, or somehow rebuilt your entire EFI partition without all of the required Windows materials (possible, especially when using multiple versions of Windows). In that case, you'll need to copy the EFI materials from the DVD, then either modify or rebuild the Boot Configuration Database using BCDedit.

Q: Can you give me an example of a scenario where BCDedit /SysStore can be used to do anything at all on an EFI system?

A: So far, no.

Anyway, hope this helps solve some problems for people, or at least gets them thinking. As a very important final point, please note that you can mount and inspect your EFI partition under Windows normally using the DiskPart: Assign technique above. You should do this at least once, to get a complete backup of your EFI partition, BEFORE you run into this kind of trouble. I recommend one backup into a subdirectory on your C: drive, and one on a USB flash drive.

Sorry that's so long-winded. I need to turn this into a proper article at some point, but there are so many people who are SO frustrated that I felt the need to document my experience as completely and rapidly as I could.

  • 1
    Actually, MOUNTVOL does let you mount the ESP. You use MOUNTVOL letter: /S.
    – Yuhong Bao
    Commented Apr 28, 2013 at 2:03
  • So when you mount that EFI partition and don't find anything at all, how to proceed? I was thinking that bcdboot c:/windows /s i: /f ALLor such would get me started, but that just gets me "BFSVC Error: Failed to set element application device. Status = [c00000bb]"
    – rainabba
    Commented Jul 10, 2015 at 17:45
  • Despite seeing that error ever single time, it now appears that I have the EFI folder on that drive where I did not before. Still can't do much else without errors and can't boot, but that's something at least.
    – rainabba
    Commented Jul 10, 2015 at 18:08
  • Decided to try another route entirely. I plugged in another flash drive, wiped it, give it a drive letter then repeated using it as the target instead of my EFI partition. In short, I'm not booted into my Windows install, but off of that flash drive. I was NOT able to get booted off my EFI partition despite it having the files, it being the first partition (EFI, fat32, has the files) on my first drive.On the upside, this is an interesting way to keep someone out of my system. I just take this "key" out of my system and it won't boot.
    – rainabba
    Commented Jul 10, 2015 at 18:24
  • 1
    Just a small tip about diskpart: all diskpart tokens -- both verbs and nouns -- are uniquely distinguished by their FIRST THREE LETTERS. In plain English: you can type (say) "lis par" for "list partition" etc Commented Feb 14, 2021 at 20:59

Windows 8 is still not out in final form, so problems are to be expected. You are in an area new to most of us, where the commands we used to use may not work anymore. To the commands listed by @soandos, I add this one that completely rebuilds the BCD :

bootrec /rebuildbcd

Try also to use the Advanced boot menu from Windows 8 and let us know what happens.

If nothing works, the article Repairing Windows 7 when they fail to boot has some advice on using bcdedit to correct boot errors. It would in any case be interesting to see what is the output of bcdedit on your computer.


These links might contain some helpful ideas :

Recovering the Windows Bootloader from the DVD
Windows 7 Boot Manager Recovery Problem
Windows 7 Suddenly Won’t Boot – Repairing the Windows 7 Bootloader

  • I have added some links that could be helpful, although pertaining to Windows 7.
    – harrymc
    Commented Aug 27, 2012 at 20:08

The easiest way:

  • Follow the steps from the post above to locate BCD file and go to its directory.

  • If BCD file is hidden, type attrib bcd -s -h -r and press Enter. This will allow you to modify and overwrite the file.

  • Type ren bcd bcd.old and press Enter. This renames the current BCD file.

  • Type Bootrec /RebuildBCD and press Enter to force Windows 8 to rebuild the boot menu from scratch.

  • Exit command prompt and shut down. Remove Windows Recovery Media and reboot. You're done!


Under DISKPART I had only vol 0 or D (the DVD) and vol 1 or C (the Windows NTFS partition). Nothing worked for me until I made vol 1 ACTIVE.

After exiting DISKPART I only typed:

bootrec /fixboot
bootrec /rebuildbcd

then the system was properly repaired. I didn't use

bootrec /fixmbr

because I was using GAG (gestor de arranque gràfico) on MBR for multiboot.


After 6 hours of struggling, I managed to fix my Windows 8 boot issue.

Today, after a usual restart, I got the message MBR not found or similar to that, I dont remember any more. I tried bootrec commands, Windows automatic repair (it couldnt find any installed Windows), a million other ways and nothing.

The problem was when I executed bootrec /rebuildbcd it went normaly, and then when I had to enter yes if I want to save the configuration, I got the message, the file is not accessible because it is used by a another process.

After hours of mind cracking, I have finally solved it.

In this order...

  • First, I booted the easeup partition master and FORMATED the system reserved volume which I assigned as active later (in which my boot folder was). When I rebooted I got an error NTLDR missing.

  • Then I booted in Windows recovery, opened a command prompt and entered bootrec /fixmbr, /fixboot, /scanos, /rebuildbcd(which now executed fine :] )

  • I exited cmd and clicked on automatic repair.

  • Then, I was able to select Windows 8. When I rebooted, I could see the Windows 8 logo.

  • 2
    Heads up: this answer appears to be an MBR disk. On a GPT disk, diskpart.exe returns this message when marking a volume active: "The ACTIVE command can only be used on fixed MBR disks." Commented Sep 3, 2016 at 7:45

Use: bootrec /fixmbr (updates the MBR, probably won't do anything in this case, but won't hurt either)

bootrec /fixboot to re-write the boot sector of the system partition.

bootrec /scanos to scan for the OSes that are on the drive and add them to bootloader.

Just run the commands in order.

  • Downvoter care to comment?
    – soandos
    Commented Oct 29, 2012 at 0:07
  • 2
    The bootrec /fixmbr command does not apply to the author's problem or situation.
    – Ramhound
    Commented Mar 3, 2015 at 16:05

I've managed to fix it by using the following command in the recovery console:

 bootcfg C:\Windows /l en-us
  • 2
    This tool is only for boot.ini which is for Windows XP and older oses.
    – Elmo
    Commented Aug 26, 2012 at 14:31
  • 1
    This does not pertain to EFI bootloaders. Commented Sep 17, 2015 at 17:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .