For reference here are my system specs:

  • Cooler Master Sniper Scout tower
  • Intel Core 2 Quad Processor Q6600
  • Intel G33 Motherboard
  • 6GB DDR2 RAM
  • Radeon HD 4870 GPU
  • 1TB SATA Drive 7200 RPM
  • OCZ ZT Series 650W PSU
  • Windows Vista 64-bit Home Premium

I'm having an issue where at certain times my display starts to become corrupt, with artifacts appearing. This might happen while playing a game, but it can also happen without using any CPU or GPU intensive applications running. I then see the error message from Windows which says Too many 16-bit programs are running. Then the display becomes completely corrupt and I have to shut my PC down. I wasn't even aware that I was running any 16-bit programs, I'm honestly stuck if anyone can help me out here.

Update 1, I've run a:
Virus Scan
Spybot scan
Furmark Test
Windows memory test
Video card memory test

...and all of them have come back with no problems.

Update 2:
When my PC is idle there are about 55 processes running and 6 icons on the right-hand side of the Windows taskbar, and the CPU is at 1-4%

Also when idle the system's GPU and CPU are approximately 45oC and all other measurements hover around 25-35oC. When under load, all temperatures stay basically the same except the GPU which goes up to about 60oC.

And yes all of the power connections are installed correctly.

  • My knee jerk reaction... Virus scan AND Root kit scan. – Everett Aug 13 '12 at 19:52
  • Virus scan, root kit scan and Memtest (the corrupted display points towards a memory problem). – Renan Aug 13 '12 at 19:53
  • 1
    @Renan: Root kits on 64 bit? I don't think so. – Tamara Wijsman Aug 13 '12 at 21:08
  • 4
    @TomWijsman - theregister.co.uk/2010/11/16/tdl_rootkit_does_64_bit_windows Just an FYI – Everett Aug 13 '12 at 21:12
  • 4
    @Everett: Well, while there might be a possibility there are barely any. Most people know of 64 bit for the increased memory range, but you should also know of 64 bit because of the extra security it offers. Drivers has to be signed, exploits for 32 bit no longer work, and so on... – Tamara Wijsman Aug 13 '12 at 21:12

You seem to be running a 64 bit operating system, please note that such operating systems can't even run 16 bit programs. For more detail, see this KB article. So, that error makes no sense at all. It would be interesting to get an idea of where that error is coming from; any other details about that message box (or event log) should help you find a explanation online why that message box is appearing, please update your question with these details or ask a new question.

As for the graphical corruption, you have mentioned that you just installed new RAM. So, running memtest to figure out whether the RAM is stable should be the first thing to do. If you have upgraded from 2 GB to 4 GB and thus have two sticks in total, it might be easy to try booting with one of the sticks and later booting with only the other stick in order to test both apart and figure out which of the two sticks is unstable.

There must be something (either software or actual hardware) that's corrupting your computer after a certain non-deterministic event, as this kind is out-of-place as I stated in the first paragraph. You can find more things to try in my last comment below.

  • Humm, I ran the "Memory Diagnostic Tool" on windows and it said it detected no problems. Something else I noticed is that the problems occurs following periods of extended gaming, could it be a graphics card issue? – Ryan Stull Aug 14 '12 at 2:05
  • I also tested my gpu with Furmark and didn't seam to have any problems – Ryan Stull Aug 14 '12 at 2:47
  • Yeah, and the temps are all good, the cpu stays at around 50C, and the GPU never goes above 70C while under load. – Ryan Stull Aug 14 '12 at 18:10
  • 1
    @Ratz: I would still suppose some kind of corruption, maybe in the actual hardware itself, because that message is really out-of-place. Are all your drivers up-to-date? Are you running with the bare minimum components? Can you try to disable Aero in the services and/or disable transparency? Have you tried cleaning out your software list and start-up items with the bare minimum needed? Can you check with Process Explorer (it has a aim icon in the toolbar which you can drag to the message box) to figure out the offending process? – Tamara Wijsman Aug 21 '12 at 21:58
  • Is there a way to test my graphics hardware for corruption? – Ryan Stull Aug 22 '12 at 18:59

In Windows Vista 64-bit this message is evidently bogus, as 16-bit programs cannot run on 64-bit. Microsoft (or another product) is apparently issuing the wrong message for some unknown error-condition.

I would suggest the following :

  1. Search the Event Log for a more detailed error message (if one exists)
  2. Use an Administrator login (if not already the case)
  3. Temporarily disable UAC as a test
  4. See if the problem happens in Safe Mode boot

This is an often reported bug that exists due to an incompatibility between certain security products and this update KB2442962 for Windows, which causes consent.exe to not show up. As a result, this calls a procedure to report you with an error for that situation, but it appears that they have not updated that error for 64-bit editions of Windows. At least not in Vista...

To resolve this, there are multiple solutions possible:

  • Disable UAC.

  • Uninstall update KB2442962.

    MS10-100: Vulnerability in Consent User Interface could allow elevation of privilege.

  • Do a system restore to a point before update KB2442962.

  • Reinstall your computer and make sure you hide the KB2442962 update.

  • Attempt to figure out what security software is incompatible with KB2442962.


I replaced my graphics card and the problem has completely resolved. There must have been some short or damage to the actual hardware itself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.