When I download a .zip file using Google Chrome on Linux, upon clicking it the .zip file opens my Downloads folder in Nautilus, not the .zip file in file-roller. Ironically, Google is mum on the subject, with most results pointing to Windows 7's Default Programs dialog.

Has a way to fix this arisen since the last Google Chrome update?


You have to change the application that opens .zip filetype archives with the command xdg-open, which is the way used by Chrome/Chromium to open files.

To do that, follow these steps:

  1. Find the name of the program that you want to use. In your case is file-roller, and in my case was engrampa, because I'm using Linux Mint with MATE.

  2. Open a terminal and write:

    xdg-mime default programname.desktop application/zip

    Change "programname" with file-roller, engrampa or any other program you want to use.

  3. If you want, test it by writing:

    xdg-mime query default application/zip

    And it should say file-roller.desktop, and now write:

    xdg-open /path/to/a/zip/file.zip

    And it should open on your program.

Now Chrome/Chromium should open them right.


I'm using Google Chrome ver. 21.0.1180.75 on Ubuntu 12.04. When I download a .zip file from my e-mail account, I click on the little blue dropdown arrow to the right of the filename in the download bar and then on always open files of this type. Also, check the Downloads section in Chrome's advanced settings and you should see what is shown in the lower part of the picture. Subsequently, downloading a .zip file automatically displays the .zip file in File Roller and not in Nautilus.

auto-open zip files

  • 1
    That made no difference. It still opens in Nautilus instead of file-roller. – NobleUplift Aug 28 '12 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.