In Opera, on any given page, you can right click the page and change the setting (under "reload every") for how often the page should reload. This is quite handy, but it defaults to the page's default on every site, and I have to manually change the setting to what I want each time. How can I make the default setting be to never auto-refresh?

  • Go to Tools menu and select the preferences option then go to Advance tab and select the Network option in left tab option menu. Now you will see an option Enable automatic redirection unchecked it. I think it will do the job for you. If it helps I'll post it as answer. See the screen shot. – avirk Aug 16 '12 at 3:46
  • @avirk, that is a semi-effective workaround, but it has the unfortunate side effect of having to manually click through each redirect (even a simple google search will have more than one) as well as just plain breaking some sites. I'd certainly upvote that if you made it an answer, because even a workaround is better than nothing, but I'm looking for a way to do only what I outlined in my question. – Fambida Aug 16 '12 at 7:44
  • It doesn't matter for me about upvote, I just did it to help. Unfortunately I have not find any way to use any .ini or config settings for this. For Opera config you can check out this Link. Use Ctrl+F and type Reload and you will get the entries not sure if they do the trick for you. – avirk Aug 16 '12 at 13:58

Yes that option is not global. Its bound to that particular site only. You need to change it for every site.

|improve this answer|||||
  • 1
    That's... not an answer to my question. An answer could range from changing an about.config setting to editing a line in an .ini file to installing or writing a plugin to editing the source and compiling my own version (and preferably providing links to said source and a quick rundown of what's what). – Fambida Aug 15 '12 at 12:39
  • @Fambida: Sometimes, "you can't do it" is the correct answer, whether it's what you want to hear or not. (I don't know for sure that there's no possible way of doing what you want, but I don't know of any way to do what you're after either.) Good question, though, hence my upvote for this answer and your question. – Amos M. Carpenter Aug 19 '12 at 22:58

Opera doesn't auto-refresh pages by default.

If you meant auto-redirection instead, there's only avirk's suggestion that comes closest to changing the behavior. A list of all settings can be found here. Didn't found a way to change the time...

If you need anything else, you could write an extension...

|improve this answer|||||
  • 1
    You're correct that Opera doesn't auto-refresh by default. What it does do by default is follow the page's settings. (the highlighted bit is Opera's default) That is what I wish to change. I am already going with your suggestion of just writing my own extension. – Fambida Aug 17 '12 at 4:01
  • @Fambida: But isn't that always Never? – Tamara Wijsman Aug 17 '12 at 7:43
  • Unfortunately no. Thankfully, it's almost always never, but the website that sent me on this current crusade had two of the same flash video which would autoplay (out of sync with each other, I may add) and after finding and pausing both of them and leaving the tab in the background, 3 minutes later the page auto-refreshed and the damn things started autoplaying again. – Fambida Aug 17 '12 at 12:50
  • @Fambida: Alternatively, you could look into a way to block flash instead. If Opera has userscript support, it could be as easy as removing the elements or automatically calling some .stop() function on the embedded player. But well, I suppose that the website itself shouldn't refresh either. – Tamara Wijsman Aug 17 '12 at 13:33
  • 1
    @Fambida: Under Preferences > Advanced > Content, I have "Enable plug-ins only on demand" checked. This way, flash components on pages don't start playing unless I allow them to. Handy for annoying ads as well as flash videos, unless of course you want some components to start automatically. – Amos M. Carpenter Aug 19 '12 at 23:48

For opera web browser only

for adverts try adding them to your blocked contents section, Ctrl + F12 > advanced TAB > Content > blocked content > add then enter the url of the site that supplies the advert.

eg: this site is "superuser.com" but one of its advert comes from

static.adzerk.net (shown as careers 2.0) add the "static.adzerk.net into the block content section and from then on ANY site that shows ANY advert from "static.adzerk.net will not be shown.

more advanced users should use the inspect elements option when right clicking on a page, this will let you get the advertisment suppler, reason is.. william hill betting advert is not supplied or hosted by william hill beting but a 3rd party advertiser such as 1click or 7ad. hope this helps and sorry if its a little hard to follow.

|improve this answer|||||

Not the answer you're looking for? Browse other questions tagged or ask your own question.