I am using Windows 7 Professional x64. When trying to turn some features on the following error occurs, and I am unable to install the features:

"An error has occurred. Not all of the features were successfully changed"

I am a user with admin rights (as someone mentioned here the problem being non-admin user).

I am trying to turn on "Application Development Features" like .Net Extensibility and ASP.Net under "World Wide Web Services".

After Windows tries to turn these features on, I receive the error message above.

What might be causing this problem, and how can I get these features installed?

  • Right now there isn't enough information to answer your question. If you can edit your question to let us know what you're trying to install and what sort of error shows up, we may be able to reopen it and get you an answer. Some screenshots would particularly help. – nhinkle Aug 15 '12 at 18:16
  • nhinkle, I tried to upload the images for details, but haven't enough reputations to do that, will above details be enough? – Nexus23 Aug 16 '12 at 8:24
  • Nexus, I edited it about more to make the question more clear, and reopened it for you. If you post a link to the image in the comments, I can edit that in for you. – nhinkle Aug 16 '12 at 17:15

Doing some more research on this problem ultimately I found the reason.

I was unable to install ASP.Net and related feature on my system because I installed visual studio prior to IIS and ASP.Net was installed as part of .Net framework installation. Windows 7 didn't pickup that information and when I was trying to install ASP.Net through "Turn Windows features on and off" in control pannel, it was showing the error and logging it in windows log under Application logs that there is already an instance of ASP.Net installed.

I repaired the framework in Add Remove programs and then tried to install ASP.Net and related features and it worked ok. It was a matter of precedence.

IMPORTANT: Install IIS first and then Visual studio.

  • I'm also having this same problem. However, when I go to change a program to repair the ASP.NET framework, I only have the option to uninstall - not repair. Do you know a workaround? – iaacp Feb 12 '15 at 19:26
  • Does it not say uninstall/change then have a repair option when clicked – James Oct 30 '15 at 14:47

Ignore the error and just run this command:

C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -r

As you can read here this installs ASP.NET 4 and updates existing applications to use the ASP.NET 4 version of the application pool. It updates both the IIS Classic mode and the IIS Integrated mode handler and script mappings in the IIS metabase.

Your Answer


By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.