In Windows 7 opening Run dialog (Win+R) and confirming with Ctrl + Shift + Enter ran specified command elevated.

In Windows 8 this trick doesn't work anymore and I miss it a lot!

Is there a way to get this feature back?

  • never had to do that when using win+r in a admin user account in W7, it ran elevated by default.
    – Moab
    Aug 15, 2012 at 22:12
  • 2
    @Moab Not if you have UAC enabled. Aug 15, 2012 at 22:13
  • 2
    For me, this only works in the Windows 7 Start menu, but not in the Run dialog. And that functionality is still there in Windows 8. Aug 15, 2012 at 22:23
  • Not on any of my systems with UAC enabled.
    – Moab
    Aug 15, 2012 at 22:24
  • 2
    @OliverSalzburg Is the shortcut Win+R (show Run prompt) dead in Windows 8? This is one of the most useful Windows shortcuts in my opinion. Along with Win+E (show Explorer), and Win+D (show Desktop).
    – Samir
    Aug 3, 2013 at 22:17

3 Answers 3


Do not press Win + R.

Instead, just press Win and type the command directly into the Metro interface. As you type, the search interface will start bringing up possible matches, but just ignore them. When you're done typing, press Ctrl + Shift + Enter, and the command will run elevated, as expected.

This works perfectly for full commands with arguments. It also works for commands without arguments, but with some caveats (matching shortcut, multiple executables, etc.). I have not generally found these to be a major problem.

  • 1
    Thanks! I just realised that I have been using Win / cmd / Shift+Ctrl+Enter all the time. :) Aug 16, 2012 at 8:30
  • This does not seem to work for me all the time when using parameters. Very often, Windows search will open with the exact search term displayed on the left which I can then click to execute the command, but I wan’t it executed when pressing enter instead. For example cmd /c echo.foo.
    – poke
    Jan 9, 2014 at 19:28
  • 1
    This behavior seems to have changed in Windows 8.1. If you have parameters, you can press Ctrl-Shift-Enter a second time to execute the command from the search results screen. Or press the down arrow key before hitting Ctrl-Shift-Enter.
    – taoyue
    Jan 23, 2014 at 0:38
  • Figured it out, and posted an answer below (it restores the functionality via a local policy). Oct 24, 2015 at 19:09

Okay, I figured it out. It seems to be caused by new a feature of UAC called "Admin Approval Mode" or "AAM". You can disable this feature and (at least with UAC turned off as well) Win+R will run applications as elevated by default. -- I have tried this on 3 machines now and it has worked for me every time.

Here's how to go about disabling it:

  1. Open Local Security Policy editor (on the Start screen type "secpol" and right click it, "Run as administrator").

  2. From the menu on the left, expand "Local Policy".

  3. Under the expanded "Local Policy" heading, select "Security Options".

  4. On the panel on the right find "User Account Control: Run all administrators in Admin Approval Mode", open this setting and change the value to Disabled.

SecPol - User Account Control: Run all administrators in Admin Approval Mode

  1. "OK" out of everything, and reboot (at least on my machine it said that a reboot was required, YMMV).


If it all worked right, when you hit Win+R at your windows desktop you should see the little shield below the text box that says "This task will be created with administrative privileges."

You can see that this works.

(Note: Depending on your luck, you may have to turn off UAC as well.)

  • 1
    Verified, this works in Windows 10 too. Oct 27, 2015 at 3:01
  • THANK YOU. Been searching all over the place for weeks for this.
    – Jake
    Feb 7, 2018 at 16:35
  • Can confirm this still works on Windows 10
    – Addison
    May 25, 2020 at 14:16
  • Good man, thank you
    – Vadim
    May 16 at 11:14

^ ^ I just signed up to comment about this, but I don't have 50 reputation to reply to the above. So I will reply in a new answer.

"Okay, I figured it out. It seems to be caused by new a feature of UAC called "Admin Approval Mode" or "AAM". You can disable this feature and (at least with UAC turned off as well) Win+R will run applications as elevated by default. -- I have tried this on 3 machines now and it has worked for me every time."

This indeed seems to be the only way to make the Windows Start Menu 'Run Command' ALWAYS run with administrator privileges. If you have a machine like me that is a Windows 'Home' product, the registry key can be found at

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System clicking on that, on the right side there is 'EnableLUA'. Right click 'Modify' this to value '0' instead of '1' and that does the same thing of disabling UAC. Which apparently, is exactly the same thing as 'built in admin approval', or that the admin approval only works when there is the UAC enabled to 'control' the different user/admin account privileges/access rights.

I've ended up giving up and making an admin enabled shortcut to cmd prompt and placing it above the 'programs' folder on my start menu, as this is pretty close to near my 'run' button (just above shutdown on my modified 'classic Start Menu' modded Windows 10 Home edition). Otherwise with UAC off, I am able to get admin rights on my run command in the start menu BUT CANNOT get rid of the error (doesnt seem to do much, stuff works after clicking 'ok' on it but don't like seeing it) - http://www.bleepingtech.com/windows-8-fix-this-app-cant-open-for-built-in-administrator-account/ This app can’t open for Built-in Administrator account please sign in with a different account and try again .. trying that fix but I don't think there is any way to get admin rights on the run command, without disabling UAC, which in turn gives that error..

  • Thanks for posting this! I don't have a lot of experience with the "Home" versions of Windows so that's helpful, but yeah, in Windows 8 and 10, it's a little more painful, because if you turn UAC off completely, the "apps" don't seem to run. -- I'd call this a major bug in the OS -- If you don't use "apps", it's fine, but it's terribly annoying in Windows 10 where even the calculator program is an "app" now. Mar 28, 2016 at 21:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.