I have a Belkin FSD7632-4 ADSL wifi router. Ever since I got it, I've faced this problem of websites timing out.

For example, I go to flickr.com, and the images won't load because they come from farm1.static.flickr.com. Either I wait 10 minutes or so until the timed out sockets are closed and retry (with variable results) or I reboot the router.

This happens irrespective of whether I use wired or wifi network.

I'm in India, using Airtel Broadband, and if I use my ISP supplied Beetel 220BX ADSL router (which has no wifi and only one LAN port), everything works fine. I copied over the broadband settings from my old router:

  • VPI/VCI values=1/32
  • Encapsulation=LLC
  • MTU=1492

I have not enabled any firewall on the router.

Is there anything else I can try? Or is it a defect with the router and should I take it back for a replacement? I bought it just 2 months ago.


It would be worth checking those settings on your isp website since there is some variation from ISP to ISP. The fact that it started when you got the new router however suggests that perhaps the new router cannot cope with some of the demands that you're placing on it. One thing that particularly stresses routers is P2P file sharing since it tends to make lots of simultaneous connections. If you run any P2P software including TV download services (like BBC iplayer in the UK) try shutting them down rebooting the router and seeing if your still getting time outs.

If that helps it might be worth changing the DNS settings on your PC to use OpenDNS or your ISPs DNS servers since the default is to use the inbuilt one of the router and this can cause problems.


I believe the 1492 MTU only applies to PPPoE, which, if you're not using that to 'sign in' to your isp's DSL line, you don't need it set to that, but it shouldn't hurt anything. Generally these kinds of problems you're describing stem from a bad DNS. The Belkin router might follow the popular setup of acting as a DNS caching server, while this sounds like a good idea it is not. There's two ways to go about fixing this.

  1. Either configure your router's DNS settings to always use the DNS from your ISP, which should work since being directly connected is working fine for you.
  2. Or configure your machines to ignore the DNS settings provided by the DHCP response from your router (which might advertise your router as the DNS server) and manually configure them to point to the ISP DNS addresses.

I had the same issue, my network died every 10 minutes. When I plugged a computer directly in the wall it worked fine.
The problem was that my router held an ipaddress from my ISP for too long, which according to Belkin is normal:

This addresses a common scenario where the router has been connected to the 
Internet for an extended period and holds an IP address (DHCP lease) for a
longer period of time than your Internet Service Provider (ISP) allows.

This is normal and does not indicate any issue with your Belkin router or ISP.

I solved it by resetting the router to its default settings (as described by Belkin)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.