I have a motherboard ECS H61H2-M2 1.0 bios

One day I noticed that aero doesn't show up unless I disable the sound.

I guess it just need a better driver.

So I search for google and find a driver. What I found is something called bios update.


It doesn't look like a driver. It has a file with extension ROM

So I run afuwinguiP.exe

And then there is an option called "Flash".

It looks like it's reprogramming my ROM. That's while windows update is actively updating the computer.

Then the computer restart doesn't want to reboot.

I tried to install windows 7 but installation never finish.

I can access BIOS and stuff though.

I have the original CD of the motherboard. However, that CD is not bootable and the only to install it would be to install some operating system and then use the CD.

However, I can't install windows 7.

I look at BIOS and it says that it has pxe oprom. So does the bios have a basic operating system just for cases like this?

I restart with nothing and it still try to restart windows rather than the pxe oprom.

What should I do? Is there a bootable CD that can restore ROM?

I can boot to CD rom. In fact, I can install windows 7 but the install won't finish.

Windows 7 won't restart.

Not sure what I should do.

  • Update: The answer work. However to ensure that the flashed version is copied correctly I did it again. This time with option program all blocks checked. afuwinguiP.exe Now computer don't even run.
    – user4951
    Aug 16, 2012 at 15:41

1 Answer 1


Looks like you flashed the BIOS with the same version that was already on there. Since you said you can still access the BIOS I assume you did not break anything.

Would recommend going into the BIOS and resetting to default options. Per the User Manual the option should be hitting F3 (reset defaults) then F4 (save & exit).

After reboot your OS should load if it is in working condition. Else you can boot to CD. Sometimes you need to press F12 during POST to get boot options. IE: Select boot device, disk, CD, LAN etc.

I look at BIOS and it says that it has pxe oprom. So does the bios have a basic operating system just for cases like this?

PXE is used for booting from LAN.

  • actually I can access basic dos from windows 7 cd. However, when I tried to reinstall bios it says that afudos is not compatible with my windows. I wonder where I can download dos operating system. If that's still produced. I already did reset the bios though.
    – user4951
    Aug 16, 2012 at 14:16
  • What you suggested works. Looks like when I reset bios I didn't do it right the first time.
    – user4951
    Aug 16, 2012 at 15:00
  • Now I can't even access bios superuser.com/questions/462641/…
    – user4951
    Aug 17, 2012 at 0:30
  • How do you find the user manual so fast. I can't find it by searching google.
    – user4951
    Aug 17, 2012 at 0:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .