I installed Visual Studio 2012 yesterday and during the install my path somehow got screwed up1. Since then, the icons for applications that are part of Windows are the default "unknown" icon, but other icons are fine. The applications that the shortcuts link to launch fine when the icons are clicked on.



Start Menu:

Start Menu

I have fixed my path, but the icons still show incorrectly.

Any ideas on how to flush what appears to be a set of cached icons?

1 Something took a path of A;B;C;D; and turned it into A;B;C;D;A;B;C;D;E;F; - duplicating a large part of it to that point that no more characters were available to type in the edit box in system properties. This had the side-effect of Windows reporting that it couldn't find %windir%.

  • Have you tried logging out and back in? Or restarting the computer?
    – Indrek
    Commented Aug 16, 2012 at 23:08
  • @Indrek: Yes, I've restarted several times. Commented Aug 16, 2012 at 23:10
  • 1
    Check the path for space(s) after a ; which causes everything past that point to be skipped. A path of A;B;C; D;E;F would only be seen as A;B;C. Microsoft really needs a decent editor for the path environment variable. Posting your path environment variable(s) should let others spot problems as well.
    – Brian
    Commented Aug 16, 2012 at 23:20
  • @Brian: no, there are no spaces present. Commented Aug 16, 2012 at 23:22
  • Have you tried recreating the Icon cache? See Windows 7 Desktop Icons corrupt Commented Aug 16, 2012 at 23:44

5 Answers 5


I have solved the icon issue by:

  1. Starting the Task Manager
  2. Ending the explorer.exe process (Right click on explorer.exe -> End process)
  3. Opening a command line window (File -> New Task (Run...) -> Type cmd.exe)
  4. In the cmd window type
    cd %userprofile%\appdata\local
  5. Now you need to delete the iconcache.db file
    del iconcache.db /a 
  6. Exit the cmd window by typing
  7. Starting the explorer again (File -> New Task (Run...) -> Type explorer.exe)

Now you should be able to see the restored icons.

  • 1
    You sir, are a gentleman and a saint. Perfect! Wish I could up-vote your answer more.
    – Pace
    Commented Oct 21, 2014 at 9:21
  • This one works as charm
    – starcorn
    Commented Oct 21, 2014 at 20:09
  • 5
    Great, perfect answer. It should be the accepted one. Commented Aug 6, 2015 at 11:59
  • This works for me as well Commented Jan 6, 2016 at 9:11
  • Excelent! Works perfect!! Commented Jun 12, 2017 at 13:59

for me the pin and unpin function of the taskbar did the trick

  • I can't believe this worked. Wow.
    – RubberDuck
    Commented Apr 4, 2016 at 12:15

I eventually solved this by following the advice given here, although not the advice in the article but the advice in one of the comments:

change momentarily the screen color depth to 16 bits, for example, and, when Windows asks you whether you want to keep the changes or not, click "No" to restore the original settings.

The advice in the main body of the article (about changing the view hidden folders and files setting) didn't work.

  • Yea something to do with icon caching. I had simialr issue with my chrome icon dissapearing comming back dissapearing. After a long awaited format its ok now.
    – Piotr Kula
    Commented Aug 17, 2012 at 10:20

I think that loosing the icons is only one of the symptoms of a broader problem, which is that the PATH variable gets messed up. See the following discussion on the VisualStudio forum. The problem seems to be caused by an excesively long PATH variable.

  • @MarioNeubauer's answer worked for me once, and then it came back and that didn't fix it the second time. This was the ultimate answer. Commented Apr 21, 2015 at 11:33

I right-clicked on the item with the missing icon and chose properties. In the properties dialog box I clicked to change the icon. I changed the icon (for example, from the main program icon to the document icon for that program) and pressed OK (I had to have administrator rights to confirm). I then repeated the process to change the icon back, at which point the icon was now visible.

Not the answer you're looking for? Browse other questions tagged .