7

I am converting a PDF (which I made with R) to a PNG with a command like this:

convert -density 200 foo.pdf bar.png

This generates a PNG allright, but the white background is transparent in the resulting PNG. This is not what I want, I want the background to be white in the PNG as well. How can I achieve this?

Notes:

  • I am using Xubuntu.
  • What is weird, I did the same sequence on a different linux and computer: first generate picture with R in PDF format, then convert from PDF to PNG, and on that installation it does not convert the white background into transparency, just as I want it. But, I do not know where the difference is caused (R, convert or what).
7

Try to add this setting:

-flatten

Source

  • Note that if the original PDF has multiple pages, this will result in the content of different pages superimposed on each other. – gerrit Jul 13 '18 at 15:07
0

Best way is to add -alpha remove -alpha off because -flatten merges all pages if any and would be depreciated ( -layers flatten is recommended )

New contributor
konenas is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy