I had a some problems in my Hard-drive and now the hard drive seems to be corrupted.

Its Seagate 500GB Hard-Drive

The hard drive started doing problems when i copied files to it, and started to shut down and re-apear, every now and then until it didnt get recognised even in the Bios, whenever it dose get recognised it seems it cant mount or,the partition tables got corrupted.

I ran TestDisk using GParted Live CD, and tried recovering the partition tables by running "analayze" and write to the Windows partition it showed me. after doing so i followed a guide on youtube to mount the partition. i used Partprobe->sync->and mount /dev/sda1 /mnt/

The error i get is

Cant read superblock

after that i tried mount -t ntfs /dev/sda1 /mnt/ and got:

Error reading bootsector: Input/output error Failed to mount '/dev/sda1': Input/output error NTFS is either inconsistent, or there is a hardware fault, or it's a SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows then reboot into Windows twice. The usage of the /f parameter is very important! If the device is a SoftRAID/FakeRAID then first activate it and mount a different device under the /dev/mapper/ directory, (e.g. /dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation for more details.

I have no idea where to proceed from here and need your help fixing this drive.

Note: after writing the partition tables..whenever i get to the fdisk -l i can no more see the other partitions that the disk had.. dose this mean i deleted them using the Write on the first partition?? :(

I thank you for any kind of help in the matter.

  • This does sound like a failing / damaged harddrive. The first thing you need to do is use dd-rescue or clonezilla in rescue mode to back the entire disk up onto a new harddrive that you know is working. Only then should you bother with recovering data. If you know the disk is good and doesn't have issues (tested it fully on another system, no issues with it disappearing, etc.), then try to recover the data on that system because your current one might have a bad controller. But get the data off of an unstable medium/disk – Darth Android Aug 17 '12 at 15:19
  • I see what you mean..but how can i retrieve data if i can not see the partitions anymore in fdisk -l? dose clonezilla will see the data even when the tables are corrupted? – Guy1984 Aug 17 '12 at 15:30
  • You might take a look at the answers to this question. It's possible that you corrupted the partition table, or that the partition table was already corrupt. That stuff can be fixed later though; your primary issue is the drive could die completely at any point; you want to get what data you can off of it and onto a good drive before worrying about corruption. – Darth Android Aug 17 '12 at 15:32
  • Sorry, I didn't notice your comment. Does this disk show up at all? – jmreicha Aug 17 '12 at 16:04
  • it dose show up..but the partitions do not show up anymore on fdsik -l – Guy1984 Aug 17 '12 at 16:32

I don't trust traditional imaging software unless you are certain that there are not problems with the Hard Disk.

I suggest you try dd_rescue from a Linux Live CD, I prefer Knoppix. It will make a bit for bit copy of the drive, if it encounters bad sectors it will skip over them and continue the cloning process. It will not screw any of the structure up since it is essentially just reading sectors and making a mirror image of the drive. Assuming there aren't too many bad sectors you should be able to get the majority of your data off the drive.

As I'm sure you're aware, be careful when you use tools like this, they can destroy your data if used incorrectly.


Here is an example.

In your case we want to grab the entire drive, and copy it to a second drive. Use fdisk -l to find out which drives are where. Then something something similar to this:

dd_rescue /dev/sda dev/sdb

Assuming /dev/sda is the bad drive and /dev/sdb is the good. This says copy everything from drive 1 (sda) to drive 2 (sdb). I can't emphasize how important it is to quadruple check this command to make sure you are copying the right way (bad -> good). Also be sure that the known good drive that you are copying to is at least as big is the original drive. If the original drive is 500GB you will want a replacement 500GB or higher.

  • Thank you for your help jmreicha...since i am completely new to ddrescue...can you give me a command that i need to use to recover the data from all partitions in the drive to another connected drive? the damaged drive is dev/sda1.. – Guy1984 Aug 17 '12 at 16:34
  • Take a look at my updated answer and see if that helps. – jmreicha Aug 17 '12 at 16:53
  • thank you..ill run ddrescue and come back with an update! – Guy1984 Aug 17 '12 at 16:54
  • well..i kinda stuck at logistical issues for this. i dont have a drive that is bigger then 500GB, just my 3TB USB drive but its GUI partition table (hfs) and dd_rescue gives me input/output error because of that..i bieleve i need a GNU partition tables for the target drive..cant reformat it either, have tons of important data on it..i guess ill have to get another target drive from somewhere – Guy1984 Aug 17 '12 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.