I'm trying to go up on my DDR3 from 1066 to 1333 but Windows keeps crashing upon startup; before / after login screen.

I have a EVGA X58 3X SLI Core i7 Motherboard. I upgraded from 3 Gb to 12 Gb and after installing Windows 7 Pro 64-bit, it sees all the memory.

Motherboard is: http://hothardware.com/Reviews/EVGA-X58-3X-SLI-Core-i7-Motherboard/

CPU is Nehalem i7. 920 @ 2.67 GHz There are 2 cores I think with 4 virtual cpus each.

The memory I now have is: Patriot PV7312G1333ELK Viper II Sector 7 12GB PC10666 Destop Memory

 - Memory Category      Desktop
 - Memory Type          DDR3
 - Memory Speed         PC10666
 - Memory Speed MHz     1333MHz
 - Memory Size          4096MB
 - Total Memory Size    12GB
 - Memory Modules       3
 - Memory Channels      Triple
 - Memory Socket        DIMM
 - Memory CAS Latency   9
 - Memory Timing        9-9-9-24
 - Voltage              1.65V
 - ECC                  No
 - Memory Buffer        Unbuffered

My bios is: EVGA's X58 3X SLI motherboard employs a standard issue Phoenix Award BIOS that is dialed in with a myriad of options for enabling and disabling features and peripherals, as well as overclocking and voltage adjustments.

I also have access / can use the EVGA ELEET Tuning software, but I am afraid to mess around in the bios or that utility.

The screen shots on the web page show the memory set to 1033, which is what I'm now running, but my memory is listed at 1333, and I would even consider 1600 if you thought it would take at least 6 months to destroy the memory at that speed - it would be worth it if that's a bottleneck.

  • 1
    Sounds like you may have gotten some bad RAM. When it "Crashes" does it give you a Blue Screen error? Have you tried one stick at a time? Have you run any memory tests (like Memtest86+)? – Ƭᴇcʜιᴇ007 Aug 18 '12 at 16:44
  • @techie, Yes it's a blue screen. I'll run Memtest86+ and report back. I have to reboot. I'll try to edit my ? with the report or do an attachment. – toddmo Aug 18 '12 at 17:01
  • Sounds good, you may also want to include the Blue Screen STOP codes you are getting as well. – Ƭᴇcʜιᴇ007 Aug 18 '12 at 17:03
  • @techie, Memtest86+ (latest version) reported no errors after 1:15 of testing (complete pass). It didn't have the option to save results. I booted from the iso -> dvd. It always bombs at 1333 but never at 1066. Do you still want the Windows error codes? Could the problem be mis-matched or wrong bios settings instead of a windows issue? Thanks! – toddmo Aug 18 '12 at 18:22
  • 2
    @toddmo When you get a BSOD, always provide the STOP code. Many times the STOP error code tells you exactly what the problem is. – Nate Koppenhaver Sep 14 '12 at 20:20

I actually got it up to 1600. Someone upvoted my question so I looked at it and realized, this has been solved.

It had to do with BIOS RAM settings. When I get the chance I'll post what I did. Comment so I can comment back so you'll be notified when the solution is posted.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.