My iPhone 3G refuses to transfer purchased apps to iTunes. This is causing me major problems with syncing.

Whenever I attempt to transfer apps from the iPhone to iTunes it goes through the motions, but never actually transfers anything. It displays the various apps in the info area at the top of the screen, but the progress bar never advances.

In comparison when I sync other iPhones, using the same install of iTunes, the progress bar advances and apps are transferred.

The same also happens on clean installs of iTunes on other computers, it seems to be my iPhone that is the common factor. I have tried restoring the phone from a backup, which makes no difference.

This started happening months ago and the phone has since been upgraded to 3.0 and 3.1, but the problem still persists.

Originally it was just a minor irritation, but I made and attempt to fix it which has made things worse. I deleted all the apps from with iTunes and then did "Transfer purchases" in the hope that it might fix something.

It didn't fix anything. Also, I cannot now sync at all.

If I do sync iTunes now does "transferring purchases", fails to transfer and then deletes all the apps (and data) from my iPhone. It also means I can't sync music, podcasts or anything else.

I can't sync anything else, because I can't temporarily turn off app syncing because then iTunes warns that the apps on the iPhone will be deleted.

I also tried de-authorising and re-authorising.

What can I do to get app syncing working again ?

P.S. I have considered deleting all the apps and reinstalling them one by one, in the hope that it will fix the problem. However I don't really want to embark on doing that for 55+ apps and re-entering login details etc for the apps that need them, especially as I might then find out it didn't solve the problem.


The latest update to iTunes 9 has improved things in one key aspect. If I let a sync run to completion iTunes no longer deletes all the apps from my phone. So I can now sync all my other data, even if I still can't sync my apps.


See my answer to the question for how I finally resolved the problem.

  • Note that some apps can take upwards of 20+ minutes to transfer off the iPhone/iPod Touch with very little progress shown. I'm looking at you DDR. It's one of the many reasons I hate syncing my iPod. Commented Sep 24, 2009 at 17:36
  • Maybe, but that isn't what is happening here. It works its way through all 55+ apps saying it is transferring them, while never updating the progress bar or transferring anything. Commented Sep 24, 2009 at 17:40
  • If, instead of syncing, you right click the iPhone from the left bar and just select Transfer Purchases, does it do the same thing? Commented Sep 24, 2009 at 19:51
  • 3
    are there any apps in your app list which are known to cause this problem? Commented Oct 2, 2009 at 9:05
  • 1
    I don't know Jeff, are you aware of a list of apps that cause problems ? Commented Oct 3, 2009 at 12:16

12 Answers 12


Well, it looks like I might finally have fixed it without losing all my settings/data. But I warn you, it isn't pretty and it involved temporarily jailbreaking my phone.

First I jailbroke my phone, I used the blackra1n app, but any jailbreaking technique would work equally well.

Then I used cydia to install the OpenSSH package (again any jailbrake package installed would do).

Then I ssh'd into the phone (username = root, password = alpine).

I cd'd into /private/var/mobile/library/safeharbor and took a copy of the directory listing, so I had a note of which apps I had installed. This directory is where all the data for the apps is stored.

I then deleted the file /var/mobile/Library/Caches/com.apple.mobile.installation.plist, this is the file that keeps details of which apps are install. I then rebooted the phone.

At this point the only apps showing as installed were the Apple supplied apps, cydia and blackra1n.

I then backed up the phone. I then restored to the current firmware and let iTunes restore the backup I had just made.

So now I have a clean phone with no apps installed, but importantly I still have the settings and data for the apps I had installed. I have started reinstalling my apps and they are properly picking up their data and settings that are still there in the safeharbor directory.

I have checked that syncing of apps works and am just keeping my fingers crossed that it stays that way.

The important trick here was deleting the com.apple.mobile.installation.plist file, because then iTunes doesn't know that there were any apps installed and so doesn't start deleting the data/settings when it syncs.


I found a better solution for you:

  1. change the name of the file /var/mobile/Library/Caches/com.apple.mobile.installation.plist, this is the file that keeps details of which apps are install like you said. you can just change to com.apple.mobile.installation2.plist.

  2. the iphone will create a new file almost immediately (maybe you need to start a program like the mail, or itunes)...

  3. after it created the new file. delete it and rename the original "com.apple.mobile.installation2.plist" back to its original name (removed the "2")

  4. don't need to even restart the phone, just open some programs and the setting, the sms app and the safari, the phone will get stuck a bit, as if it is loading something and a few minutes later you will see your apps returned and all is working again. Itunes can update as well. and all the programs setting reappear on the setting page.

  • I can't actually test it, as I fixed my phone many months ago. But yes, that sounds like a good solution. Commented Nov 3, 2010 at 9:50

You can eventually attempt to transfer your iPhone apps to your iTunes library via CopyTrans (no jail-breaking needed as far as I know). After the transfer sync your iPhone with iTunes and see whether the issue is now fixed.


I had a similar issue on an iPhone 3G, nothing would address it and I didn't feel competent enough to try the jailbreaking option - in the end, I re-downloaded all the apps through iTunes (realtively easy to go screen-by-screen on the iPhone) and then checked the "sync apps" box on the "apps" tab of my iPhone in iTunes.

I pressed "Sync" and then - by accident, I have to admit - cancelled the sync within 10 seconds of it starting and was very surprised to see that the iPhone now looked fully sync'd!

I then pressed "Sync" again and - to my great surprise, the phone started syncing and, after about 30 minutes, was finished, apps and all.

I did NOT loose any app data or any settings!

Clearly, this could have been a fluke but might be worth trying before going down the jailbreak route or anything more drastic.


This might not be the solution you are looking for, but the same happend to me and I had to restore the firmware and then restored my last backup. And then all was good again

  • As I said in the question I have already tried that. Commented Oct 1, 2009 at 16:10
  • Sorry, must have missed that part in your question
    – monkey_p
    Commented Oct 2, 2009 at 7:15

I'd seriously consider a hard reset of the iphone, reinstall 3.1 and let it sync from your itunes backup.

  • Already tried that, several times. Commented Oct 1, 2009 at 16:10

In your question you have said that you restored your phone from backup.

I am guessing that when you restore the backup, it is restoring the problem as well.

I think that this type of problem should be able to be solved by restoring your phone and setting it up as a new phone and then syncing everything across to it.

Having said that, I am not sure what will happen with your purchases when that happens.

If, after that, the problem still occurs then it is time to contact apple for a warranty replacement.

  • Yes I'm sure setting it up as new phone would solve the problem. But there is no "syncing everything across". Yes my contacts could get synced, but I would have to reinstall each and every one of my apps manually and then set them up with their settings and data. Commented Oct 13, 2009 at 21:00

Have you tried to "Reset all warnings" when right-clicking on the iPhone icon in iTunes, then synchronise again ?

I also got problem when synchronising my apps with my iPhone and I found that I'd clicked one time on a option like "Do not transfer applications & do not ask again".
The problem was not exactly the same, but I hope this might help.

  • Yes I'm afraid I have already tried that. Commented Oct 13, 2009 at 20:57

I had the same problem, I called apple support. They were extremely helpful and resolved the problem for me in 30 minutes of troubleshooting. Ultimately, they re-authorized the downloads of the missing tracks and I grabbed them on iTunes.

  • Tracks ? This question isn't about syncing tracks, it is about syncing apps. Commented Oct 17, 2009 at 13:32
  • From my experience with Apple support, the syncing is the same idea. She had me use free Apps to check to make sure the syncing process was working correctly. Worth giving them a call, I used the "call me at this time" feature and was immediately connected to someone who knew exactly how to help.
    – Kyle Smith
    Commented Oct 20, 2009 at 15:12

I would recommend uninstalling iTunes with Revo Uninstaller first to remove all related files. Then reinstall itunes and download the 3.1.2 software (you shouldn't have to pay since it's already associated with your AppleId.

Because you've done restores already, it seems like the 3.1.2 software you have on your computer or your itunes software or both are missing files or contain corrupted files.

This will basically reset your iphone. If you don't want to try that, you could try removing your old iphone software on your computer and redownloading the 3.1.2 software first. If that doesn't work, I would go all out and use Revo Uninstaller to remove all of your corrupt files.

  • I have effectively done the cleanest of possible uninstalls already. As part of my attempts to fix this I installed iTunes on a completely clean install of the OS. In fact I did it with two different OSes, XP and OS X. So the problem really isn't with my install of iTunes, the problem is on the phone. As you say, no doubt completely wiping the phone and starting from scratch would all most certainly fix it. But that complete wipe and manual reinstall of 60+ apps, plus settings, plus data (some of which cannot kept) is what I am trying to avoid. Commented Nov 1, 2009 at 11:14
  • If you use a lot of jailbroken applications, you can completely back them all up to your RockID through "Rock", another 3rd party Installer. This saved me loads of time when I upgraded from 3.0 to 3.1.2.
    – eqzx
    Commented Nov 2, 2009 at 4:57

I had this problem. In my case, I selected "Transfer Purchases from iPod" and iTunes would begin to transfer them and then - nothing. The same happened when I right clicked the iPhone and selected the same Transfer... option. It would start, and immediately stop.

I resolved this problem by unclicking the "Prevent iPods and iPhones from syncing automatically" checkbox in the Devices section of iTunes' preferences. (For the record, this is unchecked by default. I checked it to avoid auto-syncing confusion with friends iPods, etc.)

I hope this helps...

  • Checking/unchecking that was one of the many things I tried and I'm afraid in the case described in the question it didn't help. Commented Mar 26, 2010 at 13:01

I had the same problem just now. After reading many threads I figured out how to sort it out:

Open iTunes, plug in the iPhone/iPad/whatever...

  1. Right click on the iPhone on the left hand side menu and select Reset warnings.
  2. Click Store > Authorise this computer. (I used the same username and password that I used in the app store)
  3. Right click the mobile again and select Transfer purchases.

This worked for me perfectly without causing much of a hassle.

  • 1
    That is great that it fixed the problem for you. Those steps were one of the many many things I tried to fix the problem, but unfortunately didn't work for me. Commented Sep 24, 2010 at 14:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .