The mouse has stopped working.

Spec: Windows 7 x64 Logitech M9 mouse (wired) core 2 Duo

It is definitely not a hardware issue, as I have a dual boot system and everything works tip top on the other partition, which is a similar install on Win7x64.

This issue may have been caused by a virus, as it happened shortly after my virus scanner detected it and cleaned it.

In hardware manager, it refuses to detect that the mouse is actually a mouse.

I have removed, deleted, unistalled, updated & reinstalled all of the mouse drivers and also the USB drivers & Intel drivers. Still there remains some items not recognised in the machine config.

the mouse refuses to work, despite all of my best efforts.

Device Manager

Mouse Properties, Hardware

Any suggestions are welcomed.

  • 2
    Does a different USB mouse work? Does it work on a different USB port? Do other USB peripherals work? – Der Hochstapler Aug 19 '12 at 15:45
  • 2
    I have tried other mouse and other ports and it still doesn't work, however, other USB devices work fine. – Craig Aug 19 '12 at 18:43

Rebuilding the INFCACHE.1 file in C:\windows\system32\driverstore folder. Rename the INFCACHE.1 file to INFCACHE.1bak and then restarted the machine. After it was booted up I connected the USB device and after a few minutes the INFCACHE.1 file is rebuilt automatically. The ability to rename the file though requires to change the Owner and Permissions via the security tab by right clicking the INFCACHE.1 file and then going to Properties.

Hope this helps

  • In my case there is no INFCACHE.1 nor something similar. – derloopkat Nov 22 '15 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.