I have a USB stick plugged in my PC, which is running Windows 7.

  • In 'Computer', it won't show up.
  • In 'Disk Management' (diskmgmt.msc) it won't show up (but sometimes it will).
  • But in 'Devices Manager', under Universal Serial Bus Controllers, it is showing up.
  • When trying to format, IOCTL error occured.

When plugging in the USB stick, the light on the stick starts to flash, plus the USB stick is listed on the Devices Manager screen, its properties can be viewed. The stick is detected as USB stick, but it is not seen as storage disk (not mounted).

I've tested it on multiple PCs and they're all saying the same.

How can I make the USB stick work again? Recovering the data on the stick is not in the scope of this question.

  • 2
    • Do you need to recover data from it that you have not backed up? • Is it an especially expensive USB stick to replace? • Does it show up OK in another PC? – RedGrittyBrick Aug 20 '12 at 10:59
  • Are you sure it's not showing up in Disk Management? Did you refresh the display? If it's not showing up in Disk Management, that means the computer isn't recognizing it as a disk at all, and that's not good. – David Schwartz Aug 20 '12 at 11:25
  • You might have to accept that drive cannot be repaired, my guess something happen to it, that caused this. The fact it does not appear on multiple computers means that, its unlikely to be a problem you can fix, if it worked on even a single computer then it could. – Ramhound Aug 20 '12 at 15:13
  • You can try this app to assign a drive letter. seeme.cogit.net – user249095 Aug 28 '13 at 4:15
  • Did you try CHKDSK <drive>: /R ? It fixed it for me! superuser.com/questions/694882/usb-drive-access-is-denied/… – Noam Manos Mar 29 '17 at 13:29

How can I make the USB stick work again?

You can't.

If no computer can "see" it, you can't use your computer to fix it.

If you had time, skills and resources, you might be able to disassemble it, identify the faults and repair or replace the faulty components. This would probably cost more than purchasing a hatfull of new USB sticks.

Update: the following advice seems to have been helpful for some people

Assuming that the drive has been properly partitioned and formatted, then this USB drive probably still needs to be enumerated for this computer. Open Control Panel. Go through Administrative Tools to Computer Management. Under Storage, click on Disk Management. Locate the USB drive and it probably needs to have a drive letter assigned to it. Do so (Right click and change drive letter - make sure it's not in use at time). Should take care of the problem.

Obviously this is only useful on those occasions when the device does show up in Disk Management (you said it sometimes did).

  • But why does it show up in Devices Manager? – MC Emperor Aug 21 '12 at 10:02
  • 1
    @MCEmperor: The USB host knows a USB device has been connected but is unable to identify what type of device it is (printer, modem, keyboard, mouse, webcam, ...) – RedGrittyBrick Aug 21 '12 at 10:23
  • Okay, thanks, now it becomes clear. Is there a way to manually prescribe the system to say what kind of device it is (theoretically)? – MC Emperor Aug 21 '12 at 23:40
  • Reluctantly I suspect "you can't" is probably the correct answer in most cases. – Reinstate Monica - Goodbye SE Jun 28 '16 at 7:20

I had a SanDisk Cruzer Edge 8GB USB that was recognized but I couldn't use it. The steps that worked for me were to basically:

  1. Go to: Control panel → System and Security → Administrative tools
  2. Open Computer Management.
  3. Go to Disk management on the left, and look at your drives.

Your problem will probably be that it is not allocated on your PC.

  1. Right-click the drive
  2. Click the text at the top
  3. You will assign it and give it a letter (Choose one that isn't already taken, e.g. D)

It will assign it to your PC and you will be able to use it.


Summary in Bold.
I Also had this problem and just solved it by chance.
Yesterday I mounted my USB thru' a VMWare session on a SOE; today the same device would not mount [it is one of 2 devices I sync with daily as an offsite backup].
Looking at the Computer Management console (as described previously) I could see in 'Device Manager' the 'Universal Serial Bus Controllers' was actually recognizing the device, the icon displayed it with a small downward arrow!
... realizing that this entry came and went with the plug/unplug action, I knew this was it, and therefore nothing wrong with the ports.
After exhausting all the re-scan hardware changes, re-scan disk drives, disable, enable, re-install drivers, etc, etc., the last thing was to Uninstall this particular entry -> worked, then 'Scan for hardware changes', and what do you know, Windows installed 'new' drivers and it mounted immediately; Back to normal.


I had this recently. Reassigning the letter did nothing, until I ended the task Explorer.exe (Ctrl-Alt-Delete, choose explorer.exe, select End task) and start new task explorer.exe. The drive then reappeared.

  • To start new explorer.exe task, go to the Windows Task Manager -> Applications tab and select New Task... Type explorer.exe and press Enter (from this page). The answer here did not work for me. – Reinstate Monica - Goodbye SE Jun 28 '16 at 7:19
  • Or just open cmd (by pressing Windows key+R and then type taskkill /F /IM explorer.exe, hit Enter (process explorer.exe is killed), then type explorer.exe and hit Enter (explorer.exe is restarted). – MC Emperor Jun 28 '16 at 8:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.