I've been trying to fix this issue for a few hours now, and have ran through a large number of troubleshooting lists.

Yesterday my laptop connected to my home network just fine, today it connects, but says "limited access" and no internet connection is available. The ISP is Comcast/Xfinity, but I'm thinking it's a problem on my laptop itself, not with the ISP. When I run the troubleshooting utility, I get a message that says that it is trying to correct to an incorrect or non existent DNS server.

Here's what I've done:

  • Manually typed in a static IP address and other connection information such as DNS server and subnet mask (using my router's IP as the DNS server.)
  • Restarting the computer
  • Disabling/Enabling the wireless adapter
  • Flushed DNS cache (ipconfig /flushdns in elevated command prompt)
  • Connecting to a friend's fully functional network (I get the exact same issue.)
  • Having friends connect to my home network (their computers all connect flawlessly)
  • I went out and purchased a netgear USB wireless adapter, disabled my built in one, installed the drivers for the new one, and I still get the exact same issue, down to the same troubleshooting message.
  • I have tried to get to the router's management back end via it's IP address ( to no avail, I just get a connection timed out notification, so I cannot successfully connect to the router's management page.

Does anyone have any ideas of what might be wrong/how to fix it? I'm still googling but so far, after 3 hours straight of troubleshooting I have made no progress.


  • sfc /scannow returns no integrity violations
  • TCP/IP has been reset from the command prompt
  • ipconfig /release and ipconfig /renew have been run
  • nslookup / ping have been tried and they both fail
  • the hosts file is empty
  • I tried using an ethernet cable and hooking directly to the router, i still get the same error

The problem still persists after everything listed here.

  • What happened when you did sfc /scannow from an elevated command prompt? Also, check out superuser.com/a/464014/3463. – user3463 Aug 20 '12 at 17:45
  • So this may potentially be a bad network card. Does it work when connected directly to the router? Are there any strange entries in your hosts file? – jmreicha Aug 20 '12 at 18:42
  • I will get back to you guys on this as soon as I can get back to my laptop, thanks for helping! – JonathonG Aug 20 '12 at 19:08
  • @jmreicha I haven't been able to test it with an ethernet cord, but I have installed an entirely new NIC through USB, shouldn't that rule out bad network card? – JonathonG Aug 20 '12 at 19:12
  • So what are you using for a DNS server? Do an nslookup google.com or something similar and see what DNS servers you get. Were there any entries in the hosts file? Can you ping out to anything on the internet? – jmreicha Aug 20 '12 at 19:34

Reset the Internet Protocol (TCP/IP) on the computer. Here is how to do that - How to reset Internet Protocol (TCP/IP).

Then you should probably run Malware Bytes or SpyBot S&D to make sure there isn't anything else (malware/spyware/adware) messing with your system. A free online scan at eSet just to make sure its clean might be a good idea.

Once you know the system is clean, open an elevated command prompt and run SFC /SCANNOW to run the System File Check. When it is done, reboot and see if things are back to normal.

  • I will get back to you in a couple of hours and let you know if this worked. I don't have access to the laptop right now. – JonathonG Aug 20 '12 at 19:08
  • I reset TCP/IP, checked and re-checked to make sure there are no viruses, and ran the SFC /SCANNOW command. TCP/IP reset succesfully | No viruses | /scannow found no integrity violations – JonathonG Aug 20 '12 at 20:53
  • It did end up being a virus, but MalwareBytes, Panda Cloud Antivirus, and eSet all failed to find it. The computer repair shop found it on the first night. Thanks for your help. I'm giving you the answer because you suggested looking for viruses, and no one else answered. – JonathonG Aug 22 '12 at 16:29
  • Glad you were able to get it resolved. Did they give you any details as to what virus it was and how they cleaned it? Those details would be helpful to add to your question for others who read it. – CharlieRB Aug 22 '12 at 17:01
  • I will update the question as soon as they give me details on the virus. – JonathonG Aug 22 '12 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.