I got two laptops which share keyboard, mouse and monitor using a kvm-switch. One laptop runs Windows XP and works perfectly. The other one running Windows 7, however does not recognize keyboard and mouse.

I made the hidden devices visible and deleted the unused ones. After the reboot the keyboard and the mouse work. Windows 7 tries to find the 'missing' drivers and upon failing deactivates the devices which renders them unusable again.

Has anybody had the same problem and can help me with it?

Cheers, AC


The KVM-Switch is an ATEN Petite CS692 2-Port USB HDMI KVM Switch

The keyboard a standard 102-key Logitech USB

The mouse a Logitech M705 Marathon Mouse with an unify[sic?] connector.

No adapters for the keyboard or mouse but one for dvi to hdmi on the Windows XP machine.

  • Please add the make and model of the KVM. Are you using any adapters (usb-ps2)? – Tog Aug 21 '12 at 10:04
  • It sounds like Windows 7 has a problem with the KVM Switch in question. What does the manufactor have to say about your problem? You have contacted them right? – Ramhound Aug 21 '12 at 11:27
  • We acually ordered four of those switches all for the same setup. Mine is the only one with that problem. Additionally, the operating system can't have a problem with a simple KVM-switch since it has no way to tell the devices are not connected directly. – Anonymous Coward Aug 21 '12 at 11:40
  • Have you tried to install the driver again after uninstalling from the device manager, sorry if I could not understand it through the question. – avirk Aug 21 '12 at 14:58
  • No I haven't since there is no driver for those devices and they work perfectly fine before Windows diables them. – Anonymous Coward Aug 21 '12 at 15:10

It turns out my usb.inf-file has disappeared from c:\windows\inf. I had to copy one from an other machine. That did the trick. Now everything works again.

| improve this answer | |
  • Yes, worked for me. Windows x64 Ultimate, even i copied from an Enterprise edition. Thks! – Patricio Feb 13 '17 at 20:36

This thread definitely saves me a lot of time!

Also, For anyone who also encountered this issue and is wondering where to find the file "usb.inf". You can find a backup in the following directory:


where XXXXXXXXXXXXXXXX is a 16-digit Hex number. You may find more than one directories with this pattern, I would use the most recent modified one.

Copy "usb.inf" and "usb.PNF" from that directory to "C:\Windows\INF" may fix your problem.

| improve this answer | |

Are these USB or PS/2 devices?

From the start menu open 'Devices and Printers', right click your computer and select 'Device installation settings', then I normally select 'Install driver software from Windows Update if it is not found on my computer'.

| improve this answer | |

I would first request you to check if this USB mouse and keyboard is working on a different system(or other computer with win7) , if yes then check if the USB ports are working by connecting different USB devices. If the other USB devices are working fine then please update the Chipset drivers from the manufacturer's website and restart the system and check. If the issue still persist’ s Click on start--type device manager--expand Universal Serial Bus controller and uninstall all the USB root hub's by right clicking on each of the USB root hub's. And restart the system and check if the issue is resolved.


| improve this answer | |

I had exactly the same issue - which hit me when I was troubleshooting an issue with Samsung Kies software which was not detecting my Galaxy S2 phone correctly. I could sense something was wrong with USB so tried to uninstall and re-install my USB drivers. What is so weird is that everything seemed to be working at first, but then the keyboard and mouse stopped working. Some USB based devices did work which was so weird.

I was seeing a few items that would simply not update drivers. The items that would not work were my PS-2 KVM, the MP610 printer in-bulit USB hub, an external USB audio device (USB turntable). But the USB Controllers were detected and seemed to be working. One other issue was that on startup my PC is not giving me options for pressing F8.

Anyway copying the missing USB.Inf files fixed the keyboard/mouse and other devices. I'll re-post also if my Kies and boot up issues get's fixed. Thank heavens I had an old PS2 mouse and keyboard handy.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.