We have a machine with an Asus P7P55D-E LX motherboard. We're trying to set the default boot device to a USB attached flash drive.

We set up "Removable" as the first and only boot device in the BIOS Boot options, but it refuses to boot, UNLESS we press F8 at POST and manually select the USB option.


In Bios, it should give you the option for your USB specifically to boot from.

Try this:

In Bios, go to Advanced, USB Configuration, USB Mass Storage Device Configuration and set Emulation Type to Hard Disk.

Save and exit.

Enter Bios again, and go to Boot/Hard Disk Drives and see if USB Storage Device (it could display the name of the drive for example: Sony thumb drive)is now available in the list. Move it to the first boot slot. Save and exit.

Edit: you should probably have your CD/DVD drive as first, then your USB device after you confirm that the USB device boots up.

  • 1
    We tried that, but still the only options in "Boot Devices" are "Removable, SATA, CDROM, Disabled" ... and "Removable" still won't boot from USB. Tried a different USB port, but didn't help. – Dan Aug 22 '12 at 16:33
  • We had to change USB mode to "Legacy" in the Advanced menu. Now it's working! – Dan Aug 22 '12 at 16:42
  • 1
    +1: The restart between the two steps IS crucial (even if you have the USB listed in the boot priority list... might be from a different emulation setup...) – masu Jan 23 '14 at 17:36

I have the same motherboard and had the exact same problem.

The only resolution to get it work was to swap between USB-ports. I ended up booting successfully from a USB port next to the Ethernet plug.

  • 1
    This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review – Ramhound Jun 17 '17 at 15:21
  • 2
    @Ramhound Why is this not an answer? The poster says he had the same problem as the OP and provided a solution. – DavidPostill Jun 17 '17 at 15:41
  • @DavidPostill - Because the author accepted a different solution, and it wasn't, "use a different usb port". I suppose that technically, using a different usb port might work, but I find it unlikely that's the reason setting the default boot order wasn't working for either user. – Ramhound Jun 17 '17 at 16:24
  • 1
    I posted the solution here as the USB-port was the only thing which made the bios recognize the USB stick. I had no USB drives detected by bios. Also, the upvoted answer "In Bios, go to Advanced, USB Configuration, USB Mass Storage Device Configuration and set Emulation Type to Hard Disk." does not exists in BIOS'es from 2010 to 2012. As the previous answer may have helped the other user, it doesn't remove the fact that having a faulty USB-port will lead to a non-working solution also on bios level. It seems faulty USB-ports seems to be a problem with the motherboard (as I've had 4). – Betro Jun 18 '17 at 16:55

Worked for me.

  • Using the USB port right next to the Ethernet jack.
  • Using a USB Win 10 install (MBR).


  • Main>Storage Config>Config Sata (AHCI)
  • Advanced>USB Config>USB Functions (Enabled)
  • Legacy USB Support (Enabled)
  • USB Config>BIOS EHCI Hand-Off (Disabled)
  • Advanced>USB Config>USB Mass Storage Dev Config>Emulation Type CDROM
  • BOOT>Boot Dev Priority>1st. CD-Rom
  • 2nd. USB (Will have the name)

After these have been set Save and exit> Then restart and tap F8 to open the boot menu and select the named USB.

(I only have the setting like this as it worked for me and i was able to boot to the USB, I an unsure of why it worked as some setting maybe wrong)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.