33

I am using Windows 8 Enterprise on my development machine. Most of the time, I need full administrator for debugging, changing system files, etc.

In Windows 7, setting UAC to "never notify" would disable any administrator prompts. In Windows 8 this is no longer the case. Even with UAC disabled I get prompted to grant programs elevated privileges.

Is there a way disable this behaviour?

Note: I am fully aware of the repercussions. I have antivirus, firewall, etc and am generally quite careful about what I download or install on my machine.

3 Answers 3

30

If you go to Administrative Tools → Local Security Policy, navigate to to Local Policies → Security Options, in the left side of the window, and scroll down to the button.

You should be able to disable User Account Control completely.

12
  • 4
    Sadly this also disables the ability to launch any "Metro" App at all.
    – Zyumar
    Commented Aug 23, 2012 at 19:26
  • 5
    Its not sad, Its a Windows feature, makes my day to disable the app model.
    – Moab
    Commented Aug 26, 2012 at 14:04
  • 1
    @Arnold where did you find that setting? I could not locate that. Commented Dec 5, 2012 at 21:10
  • 3
    Setting "User Account Control: Run all administrators in Admin approval mode." to disabled and rebooting did the trick for me. I no longer get applications complaining I should have started in admin mode or approval requests when copying files.
    – natli
    Commented Feb 25, 2013 at 16:22
  • 1
    For those that don't have Windows 8 Pro, the same config is in the registry in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System and then EnableLUA. Set the value to 0. Commented Nov 19, 2014 at 15:16
2

Open a Command Prompt and enter "shutdown /r /o" this will take a moment or two but eventually it will open up a menu. Choose Troubleshooting -> Advanced Options -> Startup Settings.

The OS will then begin restarting. Once it's started it will list another set of options. Choose "Safe Mode" and continue.

Once the OS has fully restarted and your at the login screen, login to the account labeled "Administrator"

From here, open command prompt once again, running it as Administrator (right click -> Run as Admin) and enter this command "net user Administrator /active:yes"

Reboot the operating system once more and let it boot up normally. Now when you login, login and use the Administrator account and you should never be prompted for UAC.

1
  • Do the step "login to the account labeled Administrator" will need Admin login ? Commented Aug 26, 2016 at 9:49
1

For windows 10, you will need to set the policy "User Account Control: Behavior of the elevation prompt for administrators in Admin Approval Mode" to security setting "Elevate without prompting".

To set this property : Go to Administrative Tools → Local Security Policy, navigate to to Local Policies → Security Options;

enter image description here

2
  • Can you explain how to set this? Commented May 25, 2017 at 15:30
  • Doesn't seem to work under 8.1 Pro either.
    – Pyromonk
    Commented Oct 17, 2020 at 22:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .