I have an emachines PC (model T5226) that I am attempting to install Linux on. I have tried multiple distros, namely Sabayon, Linux Mint, and SUSE, but at some point during the copying files phase of the installing, I get an "error number 5: input/output error", or similar. This occurs both when using a Live DVD or CD, and a Live USB drive, so the problem is not the CD Drive. However, I have thoroughly tested the the hard drive with the badblocks command line utility and found no errors (using read-only, nondestructive read/write, and destructive read/write modes).

Any clues as to what may be causing this? I am able to modify the drive just fine, e.g. partitioning it with GParted, but for some reason copying always fails at some point. I have verified the checksums of the linux ISOs I'm using, and was even able to use the Linux Mint DVD to install Linux Mint to a thumb drive, but could not install to the emachines's hard drive using the same DVD.

The hard drive is a Western Digital WD2500JS-22N, 250 gigabytes.


Yes, that's the correct machine. I cannot install Windows either, but that's because the Windows installation disk is badly scratched (I got the computer second hand). I have done md5 checks on all the ISOs I've been using, and burning them to disk with verification enabled.

I ran diagnostics on the CD/DVD Drive, Hard Drive, and memory, with no results. I couldn't reproduce the error while copying large files, however I could while recursively copying large directories, at least if the source of those directories were on the disk the OS was running from. In particular, I booted from a Sabayon live USB drive, then plugged in another USB drive, then opened the file browser as root and used it to copy /var into a subdirectory of the USB drive. When I did this, about 30 out of the thousands of files in /var failed to copy due to similar input/output errors. Interestingly, I had no similar problem when copying that same directory from the second USB drive to a third USB drive or to a partition on the hard drive. Perhaps the problem only occurs when copying files from a UnionFS source?

At any rate, I figured that the problem was not with any of my drives, but with the motherboard or the BIOS. Resetting CMOS did no good. Furthermore, eMachines does not provide BIOS updates or images for download. After much searching, I was able to find a BIOS update over at the Gateway website (http://support.gateway.com/s/MOTHERBD/Intel/4006158R/4006158Rnv.shtml). Unfortunately, Gateway only provided a self-extracting ZIP file which included a Windows program for flashing the BIOS (along with a BIOS image and some other data). I didn't have Windows installed on the machine at the time, and couldn't install it. Instead, I had to run the self-extracting archive on Wine, then pull the BIOS image out of it. Then, I downloaded an ISO image of a BIOS upgrade utility from Intel (the one here-> http://downloadcenter.intel.com/confirm.aspx?httpDown=http://downloadmirror.intel.com/14364/eng/CL0034P.ISO&lang=eng&Dwnldid=14364&OSFullname=%0a&ProductID=2613 is almost the right model number for my motherboard, but not quite), extracted the files, modified them to install the BIOS image I got from Gateway instead, created a new ISO using mkisofs, and then burned that to a CD and was able to use it to update the BIOS. Now it works fine. This also fixed the occasional problems with X.Org crashing that I was having.

TL;DR: The BIOS was faulty. With a lot of difficulty and hacking, I updated it. Problem solved.

  • you should accept your own answer, Mook. Corny as it sounds, it provides guidance for future readers with the same problem. – MariusMatutiae Oct 22 '13 at 7:22
  • This is the your machine right? : EMachine T5226
  • I am assuming Windows installs fine for you, and hence the CD/DVD drive is fine.
  • I'll take your word for having checked the hard drive thoroughly.
  • You mentioned a number of distributions / flavors, but you dint mention Ubuntu.
  • Also run md5sum on the downloaded ISO media, this is designed to verify data integrity.
  • I suggest you try Ubuntu 12.04, first a normal install, if you get the same I/O Error 5 then follow on.

Steps to Solve your I/O Error 5 :
1. Boot from the Live CD
2. Choose to try Ubuntu
3. Open a terminal window
4. Enter: ubiquity --no-migration-assistant

This should work for you. If it does, you will have to find the likes on the other distributions / flavors.


I have the same problem, found this is the "make usb tools" problem.

I've tried Universal-USB-Installer- and unetbootin-windows-584 but failed,

But using "laomaotao" installed Mint 14 KDE successfully.


enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.