I installed windows 7 x64 a day or two ago, after install I could use the HDD fine. Today I noticed it wasn't showing up in my computer, so I restarted my computer, but it still was not showing, I checked disk management, only my main OS drive there, checked Device manager, only my main drive is shown, but when I checked by BIOS both were shown.

I scanned for hardware changes, it showed up but as I tried to access it, it would "load" for a few minutes then I would get an error

"J:\ is not accessible. The specified network resource or device is no longer available."

I tried running a CHKDSK, but it just returned an error saying

"Cannot open volume for direct access."

I've tried Googling, but haven't found anyone with the same problem. Please, does anyone know how I can fix this?

P.S It worked fine in Vista x64

EDIT: I went back into the BIOS and the BIOS only recognizes it when i set SATA 1-4 to ACPI, but when I do these I can't boot into windows because I get an error "NTLDR is missing." I can only boot when all SATA ports are set to IDE.

  • The drive is most probably dead, even though it's being picked up by the BIOS. Consider restoring from backups and replacing the drive.
    – user3463
    Aug 23, 2012 at 23:05
  • What makes you say that?
    – Archey
    Aug 23, 2012 at 23:58
  • 2
    So were you able to get it to show up in the Disk Manager? What showed up? Aug 24, 2012 at 0:28
  • Is it still works in Vista? Have you tried it out with other computers?
    – avirk
    Aug 24, 2012 at 0:39
  • It doesn't show in disk manager, I have not tried on any other computers.
    – Archey
    Aug 24, 2012 at 1:33

6 Answers 6


If it reports in the BIOS, but not in the OS, it's likely that the driver being used by the OS is not compatible with the drive. It's possible that one drive is compatible with AHCI and the other with legacy IDE. When you enalbe AHCI, windows ignores the IDE drive (prob your boot drive), you are essentially trying to boot form your '2nd' drive (no os/boot loader). When you enable IDE, you can boot from the IDE drive, but Windows will ignore the AHCI drive.

Go to the m-board or PC manufacturer and see if there is an updated chipset or hard drive controller driver specifically for Win7x64. Also install firmware updates for the board.

Lastly, if you want to quickly see if you can mount the drive, bypassing the mboard controller, get a usb connector (external drive enclosure) for your 2nd drive. Boot to win7, attach your the drive via usb, and if the drive is good, the virtual usb drive controller should recognize it.

  • I totally forgot about my external enclosure. I was recognized in there(through the USB controller) but I still could not access it. I installed ASUS' AHCI controller, I could boot with all ports set to AHCI, but the drive was still not recognized.
    – Archey
    Aug 24, 2012 at 4:34
  • I booted into Windows this morning and windows was trying to install driver software for the drive, the drive shows in device manager and my computer but instead of ST31000---- it shows as just "Disk Drive". I tried running a CHKDSK /F on it but it's saying the file system is RAW. Is there anyway i could possibly recover data from the drive now, or has it died?
    – Archey
    Aug 24, 2012 at 18:16

This has to be the strangest fix I've ever applied, but it worked.

I had 3 additional drives that did not show, one SSD and two conventional HDD's. They were in BIOS, but not Disk Management. Choosing to rescan for drives did nothing.

So... went into the BIOS, changed to IDE, tried to boot up, and it failed as expected.

Back to BIOS, changed to ACHI, saved, booted up... and all the drives were how showing and working fine.

Odd. Very odd. But it worked.


Download and burn a copy of gnome partition editor. Boot off of it and see if it recognizes your drive. I fairly certain it doesnt have any tools that will fix the drive, but if you dont care about the data, you can try erasing the drive and putting down a new partition.

  • >.> I do care about the data.
    – Archey
    Aug 24, 2012 at 1:43
  • i would still download and burn it. It will at least let you know if the drive is recognizable at all. And its just a great utility to have.
    – Keltari
    Aug 24, 2012 at 1:50

I had this same issue (hard drive seen by BIOS, but not anywhere in Windows, including Device Manager and Disk Management). It was a drive removed from another computer. I can't be sure but probably the old computer's BIOS was set to use IDE and I know the new computer is using AHCI. I went into the new computer's BIOS and set it to use IDE. I then could not boot into Windows; so, I changed the BIOS setting back to AHCI. Now, magically, the hard drive giving me the issue shows up in Windows and works fine!

  • I had the same issue but was running windows off an NVMe drive in a PCIe adapter card (using Clover EFI bootloader on a usb stick to enable my elderly system to boot from an NVMe drive). New 4TB backup drive was visible in the BIOS but completely missing in Windows 10. I switched the SATA ports from AHCI to RAID mode in the BIOS and after reboot the new drive appeared in device manager! After switching back to AHCI mode it remained accessible. This was on an Dell Alienware Aurora R3 i7-2600K system with BIOS version A06.
    – Jules
    May 31, 2021 at 19:51

I removed a SATA hard drive (Windows 7), and installed Windows 10 on SSD. One of the first things I did was change from Legacy to UEFI in the BIOS (in a Dell Optiplex)

After I got to the desktop of Windows 10, I connect the HDD, but Windows did not detect it. Again, same story as others: BIOS could see it, but not Windows.

I followed the suggestion of Andrew Swihart: went into the BIOS, changed from AHCI to ATA, saved and rebooted. Windows 10 started to load, but then stalled. I went back into the BIOS, changed back to AHCI and voila! My slave SATA hard drive showed up! That is just the weirdest work-around.

  • I had the same issue but was booting windows off an NVMe drive in a PCI-e adapter card. New backup drive was visible in bios but completely missing in windows. I switched the SATA ports from AHCI to RAID mode in the bios and after reboot the new drive appeared! Switching back to AHCI mode it remained accessible.
    – Jules
    May 31, 2021 at 19:34

I had to replace the existing connection cables first, they were SATA 2 only. If your cables have no locks to prevent accidental unplugging, you might have the same issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .