Since ages I've mounted a network share (via samba to a Linux machine) in Windows 7 to access it via drive letter. This worked flawlessly so far. Until now.

Suddenly I couldn't access the drive anymore. Windows was telling me the network name (I didn't remember the exact term) was already in use. So I disconnected and tried to connect again:

net use Y: \\\work

After a long time I get a message saying

"The Local Security Authority (LSA) database contains an internal inconsistency"

A restart didn't help. The mapped share is accessible (works on other machines in the same network), so obviously something strange is going on on my machine. Can anyone tell me how I can fix this inconsistency?

Update: All machines that have saved the login information refuse with this error. So it must be something with the authorization. When I use

net use Y: \\\work /user:raphael

it prompts me for the password and then returns that error message.


I finally solved this issue:

After finding out that all machines had the same problem it was obvious it was a problem of the remote server not the client machines. So I took a look at the command history of the remote servers and found out that a colleague installed acl support, which then made samba refuse to work properly. I needed to add acl support to the smb.conf like this:

    nt acl support = yes

and restarted the samba service on my Debian remote machine with

/etc/init.d/samba restart

and it worked like a charm then.

Thanks to http://aisalen.wordpress.com/2007/08/10/acls-on-samba/ which gave me the solution.

| improve this answer | |

Some ideas:

Try creating a new user account on that system and see if the error recurs. If it doesn't, use that account instead; delete your old system account via sysdm.cpl after copying your files.

Do you have a WLAN driver that allows you to be connected to your wireless before you login (such as Intel PROSet)? Try uninstalling the WLAN card and reinstalling, and/or updating the software for that WLAN card.

Does your system have a thumbprint scanner or security card reader? Try removing or updating the software associated with it.

If you have any other type of software that extends or modifies the Windows login process, try removing or updating that software.

If none of the above resolve, I'd suspect malware has infected lsass.exe at the very least. Perform a virus scan. You may try replacing that file from a known good system or reinstalling Windows.

| improve this answer | |
  • Thanks for your thoughts. I checked lsass.exe which seems to be ok so far. I tried using a different account on the machine but the same error occurs here. I'm connected via cable LAN. I don't think it's a hardware error or driver problem as I can successfully mount another drive with another remote server. I will try another machine and see if it's maybe a problem with the target server. – acme Aug 27 '12 at 7:35
  • I tried it on two different Windows machines in the same network now, and strangely it works on one where it returns the same error message on another machine (where it worked before, too). – acme Aug 29 '12 at 7:39
  • 1
    I found out it was a samba problem with the remote server (see my answer). Thanks for your help, though! – acme Aug 29 '12 at 8:23

Just saw that error message accessing a WD Mybook Live (NAS), via: \\{symbolic name}\public . There should be No login. However, Win8.1 may have thrown that error, in error (as it were). The WD NAS device seems to be having issues with a new gateway router. Access will be fine for nearly 24 hr, then Win8.1 essentially says "I see nothing" (think of Sgt Schultz, Hogan's Heroes).

No problem accessing the NAS via: http://{symbolic name}/UI. Doing a device reboot there seems to resolve (for a time) whatever the issue is.

| improve this answer | |
  • On the gateway router, DHCP Server is enabled, and lease time 1440 minutes (24 hr). DHCP Server on the router may then be trying to give the NAS drive a different IP. On the router, Bound the MAC of the NAS to the local IP it has been (when Win8.1 sees the device). Hopefully that will resolve the issue. – NanooVisotor Dec 15 '14 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.