11

When I work with a big amount of data, I introduce formulas in Excel by using the shortcut: Ctrl+Shift+arrow. That shortcut allows me to select a whole set of data to the left, right, up or down. Yesterday, I made a change in my regional settings (changed the use of U.S. system to the metric system). After that change, I was no longer able to select data for formulas using that key combination.

Do anybody has an idea how to recover this functionality? I searched on Google, and many of the answers point to uncheck some Excel options regarding Lotus compatibility, but these options are already unchecked on my Excel.

Any helps is very well appreciated.

1
  • I am having the same problem. Ctrl+Shift+Left or Right arrow works as expected. Ctrl+Shift+Up or Down arrow does nothing. Ctrl+Up or Down arrow works. Shift+Up or Down works. But not Ctrl+Shift+Up or Down. Scroll lock is off, nothing about Lotus compatibility is checked. I did just install a bunch of Windows updates (8.1). – Jer Jan 12 '18 at 22:54
13

Check if you have not accidently activated the Scroll Lock button on your keyboard.

In case this has happened, Excel actually shows this in the status bar:

enter image description here

Then to activate it turn off scroll lock the button looks like the below link to google image search: Googled search of scroll lock

If you cannot find the button (e.g. on many laptops), you can use Window's virtual keyboard:

  1. Just Search "On-screen Keyboard" in Windows Search.
  2. Open Virtual Keyboard.
  3. Disable the Scroll Lock key by clicking on it
1
  • not always , in my case excel dose not show it but it worked thanks :) – shareef Oct 27 '15 at 7:49
2

Check if Transition Navigation Keys under "Lotus compatibility" is checked.

File -> Options -> Advanced, and scroll down to the bottom

That should be unchecked for the default behavior you had before

1

I've had this problem as well, easiest fix for me, save file, exit file, re-enter file, and it's fixed.

1
  • 1
    this was the only thing that worked for me. Frustrating not to know why. For some reason, ctrl and shift was focussing back on the formula bar rather than on the selection, as if I pressed f2. Very strange. – Some_Guy Oct 5 '16 at 14:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.