56

In Windows XP, Vista, 7 whenever one was using sevaral input languages, switching between applications would default input language for an application to defalut language.

For example when I have opened MS Word and switched input to type in Russian, switching to Command Prompt application would automatically set the input language to English (default). When I was going back to MS Word, language automatically was turning back to Russian as I left off.

So it was like a per-application input setting.

In Windows 8 an input language switch affects an enitre OS input. So if I want to type in a command in CMD, I have to manually switch to English.

How can I have Windows 8 to behave the way Windows 7 did with respect to input language switching?

83
  1. Open control panel
  2. Switch to all items view
  3. Click language
  4. In the left hand side panel choose advanced settings
  5. Check the box under switching inputs that says "Let me set a different input method for each app Windows"
| improve this answer | |
  • 1
    Thank you very much! This extremely useful for login from locking screen (usually we don't see in language indicator while typing password, right?). – Xeningem Dec 16 '14 at 12:43
  • 7
    This works for Windows 10, too. – famzah May 26 '16 at 18:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.