I have a strange problem. If I connect an external VGA monitor to my laptop, exiting the X environment in any way crashes the computer.

For example, say I am working with my two monitors (the laptop's and one connected to my VGA port) active. Hitting Ctrl+Alt+F Key should take me down to a tty. What actually happens is that the VGA screen goes blank, as you would expect, but the laptop screen, although still on, shows nothing. I know the screen is on because it is slightly more illuminated than when it is off.

When in this state, I can do nothing to regain access to the machine. I have tried:

  1. Alt+F Key (and even Ctrl+Alt+F Key, just in case) combinations and none seem to have any effect.

  2. Ctrl+Alt+Del : Nothing

  3. Magic SysRq key: Nothing

  4. Blindly typing my username and password and trying to reboot/shutdown or restart GDM or MDM: Nothing

The only thing that works is a hard reset.

The exact same behavior occurs when kiling the X server through Ctrl+Alt+Backspace, rebooting or shutdown. There is no difference if I reboot/shutdown/log out using the WM's graphical menu or if I use the shutdown or rebootcommands.

It is also not WM-dependent. I have the same problem using Cinnamon, Gnome 3, MATE and xfce4.

It is, however, VGA dependent. I have tried connecting another VGA monitor and have the same problem. I do not, however, have this problem if a screen is connected to the DisplayPort. It is, therefore, a VGA specific issue.

To make things even stranger, this only occurs when both screens are active. If either the laptop screen or the VGA monitor is inactive the problem goes away.

Finally, this problem arose when I installed the latest Linux Mint Debian (LMDE). It did not occur with the previous release of LMDE. I am not sure what has changed since I used the same kernel version in both releases (I had upgraded the kernel while on the previous release) and, I think, the same nvidia drivers. Oh, and yes, I have updated the nvidia driver.

Dell M4500 laptop
CPU: Intel Core i7
Graphics: nVidia GT216 [Quadro FX 880M]

LMDE, kernel 3.2.0-2-amd64
Xorg: 1.11.4
nVidia kernel: 295.20-1+3.2.9-1

Possibly relevant files:

Does anyone have any ideas how to fix this?

  • There are funny error messages in the logs. Have you tried a fresh installation? – harrymc Sep 17 '12 at 6:05
  • @harrymc, this is a fresh install. I said I upgraded because i was using the previous release of LMDE before. I have corrected my question. – terdon Sep 17 '12 at 10:18
  • If you have an "OPTIMUS" option in the BIOS, try to activate/disactivate and reboot. – harrymc Sep 17 '12 at 13:18
  • @harrymc, thanks I'll try that when I leave work. AFAIK, I do not have switchable graphics though so I doubt I will have such an option. – terdon Sep 17 '12 at 13:39
  • Is going back to the configuration where everything worked correctly is an option? – harrymc Sep 17 '12 at 14:05

This Ubuntu PPA has a more recent version of the nVidia closed-source driver. Alternatively, you can try nouveau, the open source nVidia X driver.

  • Thanks, unfortunately, I can't use PPAs, I'm not on an Ubuntu-based system. I had a quick look at the PPA and the drivers you mentioned are Ubuntu-specific. The version I am using is straight from nvidia so my guess is that the version numbers are not comparable anyway. I'll check if there is a newer version of the driver. Using nouveau is not an option as I really really like my compiz. – terdon Sep 17 '12 at 15:10
  • 1
    Latest nVidia is 304, so same as in the PPA. nvidia.com/object/linux-display-amd64-304.43-driver.html Sorry for assuming Ubuntu, Linux Mint (not Debian edition) is based on Ubuntu. Compiz itself actually recommends using nouveau: smspillaz.wordpress.com/2010/05/21/beware-the-benchmarks – Stefan Seidel Sep 17 '12 at 15:27

Well, LMDE Update Pack 5 came out yesterday. The problem was fixed when I updated my system. I don't know precisely which package was fixed but my current specs are:

LDME, kernel 3.2.0-3-amd64
nVidia kernel: 302.17+1+2+3.2.21-2

Oh well, all's well that ends well. On the assumption that it was the nvidia driver update that fixed it (though it may just as well have been xorg or the kernel upgrade) I am awarding the bounty to Stefan who needs it more than harrymc :).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.