29

I've moved from Ubuntu to Debian on a machine and all my sshfs mounting scripts fail with

fuse: failed to open /dev/fuse: Permission denied

now. Am I missing something simple?

5 Answers 5

28

For some reason, Debian configures FUSE to require users to be in the fuse group.

Run gpasswd -a username fuse as root, then log out and log in again. (Important step.)

9
  • 8
    just for record - this did not work for me :-(
    – gorn
    Mar 25, 2013 at 16:55
  • 5
    I am not an expert but I solved my problem by changing permissions of /dev/fuse - it had a root group and not rw for group (sudo chgrp fuse /dev/fuse; sudo chmod g+w /dev/fuse)
    – gorn
    Mar 25, 2013 at 16:58
  • I have two Wheezy... one installed from scratch, another which was upgrade from Squeeze and then installed fuse later... and I have different permission on /dev/fuse. A recent bug in fuse package ? Jun 6, 2013 at 12:40
  • Didn't work for me, neither did changing the group and setting permissions on /dev/fuse.
    – Adambean
    Jul 31, 2013 at 20:56
  • 2
    Can be : usermod -aG fuse <your-username> as root, then log out and log in again
    – Cedric
    Nov 17, 2013 at 17:42
12

There is a bug report indicating that Debian Wheezy (which seems to have the version 2.9.0-2 of the fuse package, the bug is reported fixed in 2.9.0-3) may set wrong permissions for /dev/fuse (crw------T 1 root root in my case).

As stated around the comments of the earlier posts, this can be fixed by running the following commands as root:

chmod g+rw /dev/fuse
chgrp fuse /dev/fuse

Also remember to add your user to the fuse group with, e.g., gpasswd -a username fuse.

2

Changing permissions ('sudo chmod g+rw /dev/fuse', the above omits the 'r') did work for me (in addition of course to adding my user to the fuse group).

1

I ran into the same /dev/fuse permission denied problem (unrelated the sshfs). In my case the fuse package was not installed. The package provides all the basic necessities like the mount tools, sysfs control, a new "fuse" group, and inode permission (managed by udev).

# apt-get install fuse
# usermod -a -G fuse <username>
# modprobe fuse

Last command loads the kernel module, and the kernel tells udev to set the permissions.

1
  • 1
    usermod -G fuse <username> useradd does not accept the -a parameter
    – volothamp
    Jun 9, 2015 at 20:24
0

I got the same problem. Turned out the permission for /dev/fuse was the following. I did the chmod command and it works fine. Don't know how it got into this state. It was working yesterday.

$ ls -l /dev/fuse
crw-rw---T 1 root fuse 10, 229 May  4 16:41 /dev/fuse

chmod a+rw /dev/fuse

#now it works fine!
1
  • The reason the fuse group exists is so that administrators can control who can use FUSE to mount filesystems: only those who are in the fuse group (or have root access) can use FUSE. Your solution gives access to all users.
    – Louis
    Apr 14, 2015 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.