I have a custom built computer with an integrated GeForce 6150SE on an ASUS M2N-MX board. It's connected to a Benq FP531 with a max resolution of 1024 x 768.

The computer runs Windows XP, and I had Ubuntu on it for a day or so, and the display properties in XP detected that the max resolution is 2048 x 1536. Grub2 also detects something similar, and automatically set the resolution accordingly, which means the monitor blacks out with a red warning message saying "OUT OF RANGE", and I couldn't select the OS.

I don't have Ubuntu anymore, but how would this problem be fixed so that the system detects the correct max resolution? I've already tried using the latest GeForce driver, nForce driver for the board, and I even tried installing the monitor drivers but none of that worked

Update: I just installed Arch with the proprietary Nvidia drivers (Nouveau refused to detect my monitor...) and XFCE4. Unlike my previous installations, the max resolution is 640 x 480, and the only other resolution I can use is 320 x 240...

And the weird thing that's consistent with both Windows and Linux: Whenever I access the display options, the monitor always turn black for about 1-2s as if the resolution changed, before showing the display settings window. Happens in both Windows and Linux...

The monitor is fine on my dad's custom built computer, on my mom's old Certified-Data, and on my laptop.

  • The Asus website reports that the M2N-MX motherboard has a GeForce 6100, rather than the 6150SE that you mention. I assume that this PC is a few years old. All of the info so far indicates that the PC is receiving bogus Display Data Channel, DDC, but the monitor does output good DDC. The HD15 VGA connector is in the middle of this data path. Any chance that the motherboard's HD15 connector has been damaged? Would be interesting if you could find a way to disconnect pins 9, 12 & 15 on the VGA interface, which would disable the DDC. – sawdust Aug 26 '12 at 20:59
  • @sawdust Ok. Weird... I installed the legacy driver for both nForce 430 and GeForce 6100, installed the drivers for FP531, reboot, and I got the max correct max resolution. BUT, the graphics card is still shown as a GeForce 6150SE for some reason, but that's not a big problem – Alex Aug 26 '12 at 21:36

The problem is most likely not the video driver. From the device manager, uninstall the monitor and reboot. Hopefully it will detect the proper monitor at boot. If not, manually install the monitor device. FYI, if you cant find the right one, standard VGA should work.

  • I downloaded the monitor drivers and installed it. The problem is still there. I checked the .inf and it had 1024x768 as the max resolution but it seems to be ignored. The monitor tab in display settings has the option "hide modes that this monitor cannot display" greyed out. And I know the driver is installed because it says "BENQ FP531" in device manager – Alex Aug 26 '12 at 16:57
  • Try selecting standard vga, or super vga instead of the benq monitor. – Keltari Aug 26 '12 at 17:01
  • There is only Default Monitor and Plug and Play Monitor that I can install. The default installation had Default Monitor, and I just tried PnP. None of them work – Alex Aug 26 '12 at 17:06
  • I dont have an XP machine handy, but it should be something along the lines of update driver software, browse my computer for software, let me me pick device... – Keltari Aug 26 '12 at 17:08
  • Yeah that's the only way to do it. I did that. Many times. Does not work. Still the same amount of ridiculous resolutions my monitor can't support being detected. I restarted after every change too – Alex Aug 26 '12 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.