7

Blinking cursor when editing text has been driving me crazy. Is there any way to disable it or at least make it blink less frequently? Using OS X 10.8.1.

Typing the following in terminal didn't help:

defaults write -g NSTextInsertionPointBlinkPeriod -int 100000000    
defaults write -g CursorBlink -string 0
8

This works for me (in 10.8 and earlier versions of OS X):

defaults write -g NSTextInsertionPointBlinkPeriod -float 999999999999

It doesn't take effect until you quit and reopen applications, and it doesn't apply to text views in web views, iWork applications, Mail, Notes, TextMate, or BBEdit. The value is in milliseconds.

Edit: changing NSTextInsertionPointBlinkPeriod stopped working in 10.9, but there are now new preference keys that have the same effect:

defaults write -g NSTextInsertionPointBlinkPeriodOff -float 0
defaults write -g NSTextInsertionPointBlinkPeriodOn -float 999999999999

They only apply to the same views as NSTextInsertionPointBlinkPeriod though.

  • It works for me only in a few text inputs, but in most of them it doesn't, e.g. text area it Super User (using Safari) or any other site, or text edit, etc. In most of the places where I need it to work, it doesn't work. I have rebooted my system after making the change in the terminal. – Atern Aug 26 '12 at 20:09
  • It works with TextEdit on my account, but not with form controls in web views. – Lri Aug 26 '12 at 20:14
  • Sorry, it indeed works with TextEdit, but doesn't work with other text editor I am using (TextMate). – Atern Aug 26 '12 at 20:16
  • TextMate is a little special, it doesn't use the default TextView but its own variant, which is why it doesn't inherit these defaults. @Atern – slhck Aug 26 '12 at 20:17
  • Is there any way to disable blinking cursor in form controls in web browsers and in Apple Mail? – Atern Aug 26 '12 at 20:27
1

Bug filed:


In Firefox, open about:config and create new integer ui.caretBlinkTime with the value of 0

  • +1 for filing the bugs. Do note that this isn't an answer to the question though, so it shouldn't really have been posted as an answer, but as a comment. (Unfortunately, I believe Stack still doesn't let new users post comments for some reason I can't understand.) – Adrian Schmidt May 9 '18 at 6:12
0

For text, that's hard. I use:

defaults write -g NSTextInsertionPointBlinkPeriod -float 10000
defaults write -g NSTextInsertionPointBlinkPeriodOn -float 10000
defaults write -g NSTextInsertionPointBlinkPeriodOff -float 10000

with NeoOffice and Textedit. It also works with Bean and some other applications. It does not work with LibreOffice or Pages, or did not work last I tried them.

For email, I use Thunderbird, opening about:config and creating ui.caretBlinkTime 0

For the web, I use Waterfox with the same fix. You may also be able to use Firefox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.