1

I am running the following command:

7z.exe a -t7z -m9=LZMA2 test.7z test.txt

However, I get this error: System error:The parameter is incorrect. The error only occurs if I use the -m9=LZMA2 or -m9=LZMA switches. If I remove it, it works perfectly fine. What am I doing wrong?

I am executing the command from Windows XP, 7 and 2008.

7
  • Your command works on my end - which version of 7zip are you using?
    – zb226
    Aug 26, 2012 at 21:26
  • @zb226 - Version 9.20 Aug 26, 2012 at 21:35
  • 1
    Weird, that's the same version I'm using... If I change LZMA2 to something bogus, like xyz, I get the The parameter is incorrect. error... And using LZMA works too, btw.
    – zb226
    Aug 26, 2012 at 21:41
  • @zb226 - Would anything else cause the issue? Aug 26, 2012 at 23:16
  • Tried it on another machine today and it works there as well (exactly as stated above). Did you download it from here? For reference, the MD5 hash is 42badc1d2f03a8b1e4875740d3d49336.
    – zb226
    Aug 27, 2012 at 10:30

1 Answer 1

0

I believe you're misinterpreting the meaning of the -m? switch...
-m9=lzma2 doesn't give you better compression than -m0=lzma2, that's the -mx switch.

Try this instead:

7za a -t7z -m0=lzma2 -mx=9 archive.7z files
1
  • Nowadays, with 7z 7-Zip [64] 9.20 under Linux, the options -m9=lzma2 and -m0=lzma2 lead to different files with different sizes, is it so even for windows?
    – Hastur
    Jul 18, 2016 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.