A few weeks ago my Windows XP installation began showing the 'blue screen of death' during normal use, then restarting. That went on until it failed to start completely, even in safe mode. I thought that might be a memory issue, but during the memtest (which I left running for about half an hour) there were no problems.

So I tried reinstalling the OS (tried with the CD and USB stick) and everything went fine until the part where it asks to select the partition in which to install. Here it says "hard drive is corrupt" and set up can't continue. Well, it seems my HDD's screwed up. To make sure it was a problem with the HDD, I took it off of that machine and put it in my other PC. But there the installation occurred normally, without any problems.

Also, I have two hard drives in that machine (the one in which the system fails loading), tried installing the OS in both, but it doesn't matter: the problem still comes up. oth hard drives present in the problematic machine are IDE.

Maybe it's convenient to say that I also tried booting from a Linux live cd, but before half the process had gone through, the PC restarted.

So, I'm stuck with this problem, and don't want to spend money on a memory stick without making sure that's the problem. Any tips would be welcome.

  • try changing your ide cable. it might be the problem. – RJ- Aug 28 '12 at 0:57
  • you load it via usb or cd? is your cd also connected via ide? – RJ- Aug 28 '12 at 3:39
  • Via cd. And yes, the cd driver is IDE. – Hênio Tierra Aug 28 '12 at 5:45
  • so ide cable is still suspect. try changing it to a known working one first. can you boot up from a usb thumb drive with a linux live cd on it? – RJ- Aug 28 '12 at 6:38
  • Well, I had forgotten telling you that the cd driver uses a different IDE cable: one is for the two HDDs and the other for the cd driver. Anyway, I replaced a the cable for another one which (supposedly) works. That didn't do any good. Now, I tried booting Linux live through USB and got a lot of errors, some of which read "SQUASHFS error: unable to read metadata cache entry" followed by what seems to be a memory address. The same errors show up when booting with the live cd. And of course, I tried both the cd and usb installations in other machines and they do work... – Hênio Tierra Aug 28 '12 at 20:31

Power supply - most likley the 12volt line .. causes disk drives to act funny whilst the rest of the system works just fine ..

Unplug the other drive (less load on 12 volt) & see if the OS loads 'OK' ..


First off, memtest isnt the best indicator of bad memory. It may pass memory that actually is bad.

Try removing all your RAM and use one stick at a time to see if the install process can be completed.

  • I'd have already done that, but it has only one DDR memory stick. And I have no spare DDR. :/ Is there a more reliable software to test memory than memtest? – Hênio Tierra Aug 28 '12 at 2:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.